News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15658
Latest: CharlieOhio
New This Month: 8
New This Week: 2
New Today: 2
Stats
Total Posts: 128426
Total Topics: 15790
Most Online Today: 68
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 24
Total: 27

fpp 5.4.1 and issues with buttons for pi-cap outputs

Started by tractormike21, December 08, 2021, 05:17:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

tractormike21

Hello everyone and Happy Holidays!  I hope all of your shows are running fairly stress free!

As with many of you, I like to get things ready to try for next year, since everything is up and I have a chance to test prior to taking everything down.  My show is running fine, but as soon as the season is over, I do some quick testing of things for next year before putting everything away.  Which brings me to my questions.

I have a Pi-cap that I am looking to run some pixels off of, as well as send out a DMX signal to an older Lynx controller that runs some of my older strands of lights.

I have the pi-hat installed, I have 5.4.1 installed.  Love the newer interface by the way!  Took a little getting used to, but now that I have I like it.

So here is the problem.  I have gone into the output configuration on the platform and setup the pixels as well as the other tab to setup the DMX output.

In both areas there is a checkbox to enable the outputs.

I can mouse over the box, but I have yet to be able to click on the box to enable output.

I have put pixels on the proper output as well as connected a Lynx DMX controller to the pi-hat and I am getting nothing from either when I go into test mode.

I think it is because I cannot click on the enable button.

Thoughts?  Suggestions?

Like I said, not critical for the next two weeks, but I would like to have these new functions running for my test period so that I can add for next year!

Thanks for any feedback!

Mike.

jnealand

I just got my Picap that uses DMX setup and running this week,  here is a screenshot of how mine looks in case that helps.  I suspect you are missing some info which is why you can not enable it.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

pixelpuppy

Quote from: tractormike21 on December 08, 2021, 05:17:02 PMI have gone into the output configuration on the platform and setup the pixels as well as the other tab to setup the DMX output.
What 'type' did you select for the DMX output?  Take a look at Jim's screenshot and see where he has "DMX-Open".  Make sure you have that type selected.  It won't work with Lynx if you selected DMX-Pro or Pixelnet-Lynx.
-Mark

tractormike21

#3
Thanks for the feedback from all of you!
I will look at the config, I did get to the enable button.  Update - 2 of my computers web browsers have some setting on them that does not allow me to see the colors of the button selected.  So I was probably turning enable on/off, and just couldn't see it.  I went to a third computer and everything was working fine, came back and used a different web browser and could also see the enable button.  Weird.

Now that I can enable it and then do testing, I am not getting the expected behavior, so, I will look at the config above and try a few things and get back with you.

Below are my config pages for pixels and dmx.  If you could look at and comment, I would appreciate.



Thanks you,

MIke.

tbone321

I couldn't get DMX to work on my PiHat either.  The funny thing is that it did work just fine with PixelNet.  When I stopped using the SSC's and went with a F48 V2, I switched the PiHat output to DMX for the LE's and nothing worked.  Fortunantly, the F48 also has DMX output and that one worked perfectly.

bloojoop

@tractormike21 , I know this is a older post, but you have DMX-Pro for your output type and it needs to be DMX-Open if you are using the picap.  DMX-Pro on FPP will only work with a DMX-Pro dongle, not the GPIO serial port which the Pihat uses.
--Ron A.

tractormike21

Thank you for that insight.  I will try that.
Tractormike!

Support FPP

+- Recent Topics

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

Warning/Error: Network incomplete frames hit 250. by darylc
February 05, 2023, 04:06:58 PM

F48V4-NS at 40 fps using all 48 pixel output ports? by darylc
February 05, 2023, 03:59:37 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Set Time/Date by darylc
February 02, 2023, 06:09:40 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod