News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15659
Latest: PaulDzRGB
New This Month: 9
New This Week: 3
New Today: 1
Stats
Total Posts: 128431
Total Topics: 15791
Most Online Today: 37
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 25
Total: 25

Ran into a no Internet access when using both WiFi and Ethernet, but fixed it.

Started by greggsuter, August 09, 2022, 08:01:43 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

greggsuter

My Pi4's are all running v6.0.2-2-ga4eeb9cf (v6.0 branch), which is the latest as of this post.

I've never had this issue with FPP 5.x I ran last season, but basically if I have the Pi4 connected to both WiFi (my home network for Internet and file transfers from XLights, and just basic access to the FPP web interface) and Ethernet (show network only; connects all of the E1.31 controllers and another Pi4 as a remote player...also configured the same way for WiFi).  I also have a Netgear WiFi bridge on the show network acting as an access point so I can access the show network directly without interfering with my home network, and it also has a built-in DHCP server, but doesn't affect the FPP devices or E1.31 controllers since they're all on a static IP.

IP addresses are 192.168.0.xxx on my WiFi side and 192.168.2.xxx on the Ethernet side.  WiFi is on DHCP and gets the information from my home network.  Ethernet is static.

If I were to disconnect the Ethernet cable from the Pi4, it immediately gets Internet access, but then will not be able to send data to the E1.31 controllers.  Soon as I reconnect Ethernet, Internet access disappears but I can still access the interface on the FPP from my home network, just no Internet access on FPP.

I ended up setting the Gateway IP address on the Ethernet side to the IP address of my router on my home network (192.168.0.1) in order to get Internet access.  I also have DNS set to 8.8.8.8, but that still didn't work until I reconfigured the Gateway to my router IP address.

Same exact thing on the remote player, and also got it fixed with those same settings.

My "test" Pi4 is only on a WiFi network and I just use it for testing purposes, so it has never had issues with connecting to the Internet.



I need to have Internet access on the FPP devices for SmartThings (to power on my E1.31 controllers, and other items I have automated), Remote Falcon, and so I can update FPP and/or update or install Plugins.

Since this issue seemed to be a new issue, I thought I'd send this post out for other users to see and to the developers for reference.  Hopefully it will help other users if they run into this issue also.

CaptainMurdoch

You shouldn't have a gateway on the eth0 interface in this situation.  Is that the way you had it to begin with?  If both interfaces have (different) default gateways configured, the traffic will go out the first interface listed in the routing table which is normally eth0.
-
Chris

greggsuter

Haven't tried deleting the gateway entirely, but i'll experiment with that also.

CaptainMurdoch

Quote from: greggsuter on August 09, 2022, 09:29:49 PMHaven't tried deleting the gateway entirely, but i'll experiment with that also.

You should normally only have a single gateway configured, and that should be on whatever interface has the path to the internet.
-
Chris

jonbuddy

Registered an account just to say thank you for this post, it saved me!  I have a similar network setup with the show running on eth0 on a segregated network that has no internet.  My issue was that it appears that FPP will only utilize NTP service over eth0.  So in order for my schedule to run at the correct times, I needed the service to run over wlan.  The only thing that resolved the issue was putting the gateway of the wlan network on the eth0 network settings.

Support FPP

+- Recent Topics

Warning/Error: Network incomplete frames hit 250. by JonD
February 06, 2023, 04:10:22 PM

F16V3 with 2 expansion boards at 40 fps MAX PIXELS per output? by tbone321
February 06, 2023, 10:51:55 AM

F48V4-NS at 40 fps using all 48 pixel output ports? by Poporacer
February 06, 2023, 10:27:09 AM

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod