News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15649
Latest: zj023
New This Month: 53
New This Week: 12
New Today: 0
Stats
Total Posts: 128331
Total Topics: 15780
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 122
Total: 126

Audio issues

Started by jacksonho, November 29, 2022, 05:43:25 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jacksonho

Hello all,

First year with xmas lights. When I am running my show I am getting a lot of slowdown in the audio, it starts to sound robotic at times.
Current setup is
A BBB with a HE123 cape.
~1200 12v pixel lights on 2 outputs 500/700 split
Cheap USB sound card from ebay

Once I plugged the USB sound card in the audio would play but I don't seem to be able to specifically select the card in the FPP Settings. All the items in General Audio / Video have a blank selection. 

Would this mean there is an issue detecting the sound card and playing correctly which might impact the performance, or is there a possible other issue I need to look through the logs for?

Thanks

breese


jacksonho

#2
I have done a bit more deep diving, it appears that my sound card is actually showing up in FPP because in the troubleshooting section in sound cards there is this

card 0: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]



However I think I have found a larger issue that a lot of my dropdowns in FPP settings have no option, for example
Audio and video output device
RTC and Timezone
Locale

Does anyone know why all these would be blank? Apache logs seem to indicate some issue populating the array

[Wed Nov 09 09:55:00.643592 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  file_get_contents(http://127.0.0.1/api/settings/AudioOutput/options): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized\r\n in /opt/fpp/www/common.php on line 422, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644032 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  array_keys() expects parameter 1 to be array, null given in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644116 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php


dkulp

Make sure you upgrade to FPP 6.2.  
Daniel Kulp - https://kulplights.com

Support FPP

+- Recent Topics

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by half.fast
Today at 03:19:37 PM

help getting started, next step? by Poporacer
Today at 03:01:34 PM

wifi issues on BBB running fpp v6.3 by k6ccc
Today at 02:04:23 PM

BBB / FPP sending data to ESP32 WLED by srwmemphis
Today at 04:39:02 AM

raspberry PI 3 / PI 4 by mrfix1
January 27, 2023, 07:13:55 AM

Bug in newest release by tbone321
January 26, 2023, 06:14:26 PM

Cannot Connect to F48V4-NS Through Rasberry Pi by Poporacer
January 26, 2023, 03:13:43 PM

new piCaps in the works? by Bwinter
January 26, 2023, 11:25:32 AM

DIY voucher request by CaptainMurdoch
January 26, 2023, 11:14:38 AM

Which volume to grow during setup? by RickR
January 26, 2023, 09:55:17 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod