Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16480
Latest: tcooper
New This Month: 12
New This Week: 1
New Today: 0
Total Posts: 132762
Total Topics: 16481
Most Online Today: 135
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 85
Total: 86

New K8-PB - no voltage at ports

Started by mtbehnke, June 21, 2024, 03:59:15 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all,

Just bought a new K8-PB (v2.1.0) with Pocket Beagle already mounted and and an imaged SD card.  Connected it up to a 12V Meanwell power supply and was able to connect to it via ethernet and get it all set up.

Tried test mode and couldn't get pixels to light up, eventually realizing that there was no voltage at the string ports.  The LEDs next to each port were also not lit.

Finally realized that the SD card installed FPP 6.3, whereas the K8-PB needs FPP v7 to enable the ports.  Upgraded the OS/FPP to 7.5 via the about page, but that didn't resolve the issue.  A full reimage to v7.5 hasn't fixed the issue either.

I've been using FPP for quite a few years, so I'm pretty familiar with how to set everything up.  I tried manually setting the config, having xLights upload it, tried testing via the FPP test page, the channel page and also xLights outputting directly to the controller.

I also saw on the Kulp K8-PB page it shows a 'FPP Current Monitor' page, which I haven't been able to find anywhere in FPP.

FPP recognizes that there's a K8-PB connected to it, as shown on the Channel Outputs page.  I did notice that the FPP Cape Detect Log shows "detect_cape[308]: Found cape K8-PB, Version 1.0".  My understanding is that the 2.x version of the board replaced the mini-blade fuses with eFuses.

I'm wondering if there's a bug in the cape detection that makes FPP think there's physical fuses, so it's not turning on the efuses for each port or showing the current monitoring page.

Any other ideas?



It sure sounds like a bad version of FPP and a bad eeprom for your hardware. I would suggest contacting Daniel and sort it out directly. Since he writes a bunch of FPP stuff, he will know exactly what is going on.


Sounds like it was flashed with the 1.x firmware and not the 2.0 firmware.  Easy fix with 7.5 from the Cape Info -> Upgrade EEprom  page.   Select the correct vender/board/version from the drop downs and hit flash and it should handle it all for you.

Daniel Kulp -


Upgrading to the 2.0 firmware fixed it :)


Support FPP

+- Recent Topics

Changing FPP firmware by breese
Today at 04:20:20 PM

Intro to the Octoscroller by dkulp
Today at 04:41:13 AM

xCapture Playback Issues by dkulp
Today at 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod