News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15649
Latest: Androom
New This Month: 0
New This Week: 1
New Today: 0
Stats
Total Posts: 128374
Total Topics: 15784
Most Online Today: 37
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 28
Total: 30

Sequence not running correctly from Pi 3B+

Started by TedZ, October 17, 2019, 05:14:04 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

TedZ

Hi everyone!

I made some Halloween sequences that work perfectly from my computer via an Arduino Uno through the generic serial output, but when I exported the sequences to my Pi 3B+, the sequences don't run correctly. I get random pixels and missing colors. I'm using W2811 Pixels. Thanks in advance!

Emuney18

I'm assuming you are using a hat or the pi gpio to drive the pixels.  Are you using FPP or how are you connecting to the Pi?  Did you setup the channel outputs on the Pi in FPP?


Sent from my iPhone using Tapatalk

TedZ

#2
I'm using the pi's USB with a generic serial output to am arduino. I'm new to the pi and fpp. I'm not sure how to use the gpio, and I just purchased a picap, but it is backordered. The serial output works fine with Vixen and Arduino from my computer.

Emuney18

I am not sure but you likely need to configure the generic serial output in the outputs/other tab. Are you doing this?


Sent from my iPhone using Tapatalk

Support FPP

+- Recent Topics

Set Time/Date by breese
February 01, 2023, 05:03:33 PM

Help How I use Orange Pi with FPP by tbone321
February 01, 2023, 02:41:58 PM

No network by Steve_63
January 31, 2023, 08:17:21 PM

F48V4-NS Pixel Controller using all 12 Differential SmartReceiver ports by BirdingPix
January 31, 2023, 02:26:30 PM

F48v4NS - Pi or No Pi? by rjhodgefamily
January 31, 2023, 09:25:20 AM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by JonD
January 31, 2023, 07:01:41 AM

Script/Plug-In Trigger on Data by darylc
January 30, 2023, 11:31:16 PM

Attempting to move to FPP 6.3 from 4.4 - Assigned IP is in different subnet. by Poporacer
January 30, 2023, 05:06:59 PM

Camera input for WS2811's by dkulp
January 30, 2023, 04:02:55 PM

F16v3 Won't boot or power on by rjhodgefamily
January 30, 2023, 02:22:05 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod