News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15931
Latest: pavit66767
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 129759
Total Topics: 16008
Most Online Today: 142
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 85
Total: 86

FPP install script on Ubuntu, no video

Started by ee351, December 04, 2022, 09:20:31 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ee351

Hi all,

I'm trying to get the HDMI port working on a dell wyse 3040 sbc with FPP.  I installed ubuntu server 22.04.1 LTS, followed by the FPP install script.  The fpp webserver comes up fine, with FPPD running.  However, I cannot get the video to output when playing an mp4 file.  All I see is a flicker on the screen with the terminal running.  

Is there something I can try to get video to work?  Another OS perhaps?

Thanks in advanced.

darylc

FPP is designed to be run on the supported platforms - pi/beaglebone etc.

If you run it on a PC under a linux install you're unknown territory, likely no-one has ever tested or written the support for virtual matrixes on PC's.

We would welcome a pull request to fix the issue to the fpp github repository.

dkulp

If you upgrade it to the latest master code that was committed to the repo yesterday, there is a better chance you could get it to work, but it may require some trial and error on the command line to find the right combination of flags for vlc.

If you turn on the Advanced UI, on the Video tab, and "Extra VLC Arguments"field would appear.   I would start by adding:

--kms-drm-chroma XR24

and see if that helps.   On a couple of devices I have, that's all that was needed.   Beyond that, try figuring out the dri card number and connector.   For one of my devices, I need:

--kms-device /dev/dri/card1 --kms-connector HDMI-A-1 --kms-drm-chroma XR24

to specify card1 (check the /dev/dri/ directory for cards) and the appropriate HDMI port.  
Daniel Kulp - https://kulplights.com

ee351

I added --kms-drm-chroma XR24 and now the screen goes black only when playing the video.  After the video is done, the terminal comes up.  The other settings had no effect, and this was after I changed the card1 to card0 (verified from the directory you provided).  Anything else I can try?  I feel like I'm close.

ee351

#4
Success!  I was able to get the video to play after I encoded the video file to match the native resolution of the HDMI port (1366 X 768 for this SBC).  No audio, but I'll keep playing with the settings to see if I can figure it out.

Also, is there any way to force the native resolution to 1080P?  This device is supposedly capable of 4k@30fps.  I tried force hdmi resolution under settings but this had no effect.

I'm also happy to report that a virtual matrix works with this setup, which was my end goal.  Trying different effects/videos and playback is smooth.

AlexanderMedia

The issue I had with the audio not working had to do with FPP not controlling the audio of the underlying OS.
I was able to easily set the volume in the CLI by running:
amixer sset 'Master' 100%
However, this was not kept through a reboot, so I setup the crontab to do this at boot.
I made a file in the media/scripts directory called set_volume.sh with the following:
#!/bin/bash
amixer sset 'Master' 100%

I set it to executable by running:
chmod u+x set_volume.sh

Then to get to crontab:
sudo crontab -e

I added a line at the bottom like this:
@reboot sh media/scripts/set_volume.sh

This sets the volume to 100% at start up.
It works for my testing, but I may see if I can get FPP to control the volume later.

Thanks

(Running FPP on Debian 11 on a cheap ASUS laptop)

Support FPP

+- Recent Topics

PI cannot find my F48 by MikeKrebs
Today at 09:33:58 PM

How to get deep purple color on pixels? by jchuchla
Today at 09:29:03 PM

Looking for some clarification by MikeKrebs
Today at 09:25:25 PM

Remote Player Audio Playback by MikeKrebs
Today at 08:28:51 PM

FPP OLED Display by james-s
Today at 08:21:56 PM

After upgrading to v7 I now see Forbidden when trying to connect via web browser by dkulp
Today at 05:05:07 PM

FPP 7.0 Released! by tbone321
Today at 04:33:05 PM

error uploading sequences by woody
Today at 04:10:41 PM

Colorlight card not responding to FPP by tbone321
Today at 07:52:41 AM

State of falcon pi cap? by tbone321
October 01, 2023, 06:22:14 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod