News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16481
Latest: Dronyx_belgium
New This Month: 13
New This Week: 1
New Today: 1
Stats
Total Posts: 132763
Total Topics: 16481
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 50
Total: 51

FPP 7.4 is released!

Started by dkulp, December 09, 2023, 09:19:43 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ezellner

Quote from: Poporacer on December 14, 2023, 11:31:26 AM
Quote from: ezellner on December 13, 2023, 01:26:34 PMHowever, it generated a red box error message saying the UDP was directed to itself and it was disabling that ip address.
The upgrade did not create that error, it is a configuration issue.

Quote from: ezellner on December 13, 2023, 01:26:34 PMI had two ethernet ports with the same ip address
Can you explain what this means? Did you have an Ethernet adapter on an FPP Device and assigned it the same IP address as the other Ethernet interface on the same device or different devices?

The connection to the RPi is via wifi, 10.0.0.30. There is the RPi Ethernet port (eth0) that is unused and a USB gigabit Ethernet adapter that goes to a Colorlight card for a matrix "Tune to..." sign. Eth0 was initially assigned the same IP address as eth1. Not sure why. I changed it but it didn't change the error message. I probably missed something in the process, I just don't know what.

Thanks for the explanation of why the message occurs. That's what I figured, just didn't know how to fix it for sure.

ezellner

Quote from: ezellner on December 19, 2023, 02:52:15 PM
Quote from: Poporacer on December 14, 2023, 11:31:26 AM
Quote from: ezellner on December 13, 2023, 01:26:34 PMHowever, it generated a red box error message saying the UDP was directed to itself and it was disabling that ip address.
The upgrade did not create that error, it is a configuration issue.

Quote from: ezellner on December 13, 2023, 01:26:34 PMI had two ethernet ports with the same ip address
Can you explain what this means? Did you have an Ethernet adapter on an FPP Device and assigned it the same IP address as the other Ethernet interface on the same device or different devices?

The connection to the RPi is via wifi, 10.0.0.30. There is the RPi Ethernet port (eth0) that is unused and a USB gigabit Ethernet adapter that goes to a Colorlight card for a matrix "Tune to..." sign. Eth0 was initially assigned the same IP address as eth1. Not sure why. I changed it but it didn't change the error message. I probably missed something in the process, I just don't know what.

Thanks for the explanation of why the message occurs. That's what I figured, just didn't know how to fix it for sure.
I figured it out. I had both the E1.31 and the LED panel outputs set when it should have been only the LED Panels. Both were trying to output to the same port and were in conflict. It was probably related to my struggles to get the LED panels to work using the Colorlight card a few years ago and it's been long enough since I fooled with it, I forgot how things are supposed to be set up.

james-s

Not sure where to submit a potential bug?

Until last night I was on 7.3 with one player and two remotes running Multisync/Multicast with no issues.  Then last night notice one of the remotes was not playing anything with all pixels out.  Check via browser and FPP was running but showing no packets synchronized to the remote.  Tried reboots on both players and remotes and it would play first sequence on the failing remote but wouldn't start the next sequence.  Seeing there was a 7.4.x upgrade, decided to upgrade all my FPP's instances.  Still same issue. 

After some research on this forum and FB postings, decided Unicast was the direction to go but when I went to configure it after the upgrade, I saw the Broadcast option (not sure when this first appeared in FPP).  Taking a chance to see if that option helped, I checked it, restarted and all remotes started playing all sequences.  However, the initial failing remote wasn't showing any packets on the Multisync page even though the sequence was playing on the remote controllers. 

Then deciding to go back to the initial recommendation, I configured to use Unicast.  Same results as Broadcast.  Sequences run but no packets updating on the Multisync pages.

Looking around some more, I see on difference that I am not sure is a root cause or just or really nothing.  The remote that failed initial under Multicast (FPP 7.3) and failing to report packets (FPP 7.4.3) is running a different Rasbian Release than the others.  It is running V2023-11 and the player and other remote is running V2023-8.

It may be just a coincidence the different OS and the symptoms on that remote, but I thought I would post here to see what the developers think.

For confirmation, sequences run on remotes, just this remote (FPP-K8-2) is not reporting packets now and currently back running Broadcast.



Poporacer

Quote from: james-s on December 20, 2023, 09:11:33 AMNot sure where to submit a potential bug?
On the Github page https://github.com/FalconChristmas/fpp/issues

Quote from: james-s on December 20, 2023, 09:11:33 AMSeeing there was a 7.4.x upgrade, decided to upgrade all my FPP's instances.
Quote from: james-s on December 20, 2023, 09:11:33 AMThe remote that failed initial under Multicast (FPP 7.3) and failing to report packets (FPP 7.4.3) is running a different Rasbian Release than the others.  It is running V2023-11 and the player and other remote is running V2023-8.
That isn't the Raspian Release, but the FPP OS.... It sounds like you didn't properly upgrade your FPP Devices. You should do the fppos upgrade method to get the OS AND FPP updated. The correct OS for 7.4 is 2023-12

Some networks do not handle MultiCast Sync or Broadcast Sync very well. Sometimes it will not work at all, sometimes it will work for a minute/day/weeks and then not work, or just some devices won't work...After you properly update, go to the MultiSync page on your Player and check the Unicast option to all the remotes and disable the Broadcast and Multicast options in the More Settings section and see how that works.
If to err is human, I am more human than most people.

james-s

Quote from: Poporacer on December 20, 2023, 11:00:48 AM
Quote from: james-s on December 20, 2023, 09:11:33 AMNot sure where to submit a potential bug?
On the Github page https://github.com/FalconChristmas/fpp/issues

Quote from: james-s on December 20, 2023, 09:11:33 AMSeeing there was a 7.4.x upgrade, decided to upgrade all my FPP's instances.
Quote from: james-s on December 20, 2023, 09:11:33 AMThe remote that failed initial under Multicast (FPP 7.3) and failing to report packets (FPP 7.4.3) is running a different Rasbian Release than the others.  It is running V2023-11 and the player and other remote is running V2023-8.
That isn't the Raspian Release, but the FPP OS.... It sounds like you didn't properly upgrade your FPP Devices. You should do the fppos upgrade method to get the OS AND FPP updated. The correct OS for 7.4 is 2023-12

Some networks do not handle MultiCast Sync or Broadcast Sync very well. Sometimes it will not work at all, sometimes it will work for a minute/day/weeks and then not work, or just some devices won't work...After you properly update, go to the MultiSync page on your Player and check the Unicast option to all the remotes and disable the Broadcast and Multicast options in the More Settings section and see how that works.

Thanks for the clarification about the OS being for FPP.  When I see OS and RPi, I assume Rasbian.  :)   That's what we get for assuming!  Right?  ;)

Anyway, I took your instructions and have all FPP instances at FPP 7.4.3, OS V2023-12 and set the player to unicast for the two remotes.   Initial testing seems everything is working.

Thanks for your help and the work you and the development team does to support this hobby!



Poporacer

Quote from: james-s on December 21, 2023, 12:16:05 AMThanks for the clarification about the OS being for FPP.
No worries.

Quote from: james-s on December 21, 2023, 12:16:05 AMWhen I see OS and RPi, I assume Rasbian
That is a common mistake.

Quote from: james-s on December 21, 2023, 12:16:05 AMThat's what we get for assuming!  Right? 
I am sure everyone has been guilty of assuming, look at my signature.... LOL

Quote from: james-s on December 21, 2023, 12:16:05 AMInitial testing seems everything is working.
That's great, keep us informed.

Quote from: james-s on December 21, 2023, 12:16:05 AMThanks for your help and the work you and the development team does to support this hobby!
You are welcome and thanks for spreading the cheer.

If to err is human, I am more human than most people.

SCUBA

Just for the record....I upgraded my master from 4.X to 7.4  no issues.  I was a bit reluctant because "what's not broken....Don't fix."

Also I'm running the show from a RPI version 4....no issues.  Love the interface!

BTW: why is output where you can list the multiple universes on a single line the preferred method.  Thank god for all my fingers and toes!!! LOL.  

Merry Christmas Rick, Dan and all other the developers..and thanks for all your support!


Poporacer

Quote from: SCUBA on December 21, 2023, 04:53:57 PMI upgraded my master from 4.X to 7.4  no issues.
Awesome!

Quote from: SCUBA on December 21, 2023, 04:53:57 PMBTW: why is output where you can list the multiple universes on a single line the preferred method.
Because it is far easier to find an error on one line than looking through several lines for the typo(s). And for the reason you stated!

Quote from: SCUBA on December 21, 2023, 04:53:57 PMThank god for all my fingers and toes!!! LOL.  
Why not save them even more and let xLights manage it for you?

Quote from: SCUBA on December 21, 2023, 04:53:57 PMMerry Christmas Rick, Dan and all other the developers..and thanks for all your support!
Merry Christmas to you too, thanks
If to err is human, I am more human than most people.

SCUBA

how do I let lights manage the input/output table?

Poporacer

Quote from: SCUBA on December 23, 2023, 10:57:01 AMhow do I let lights manage the input/output table?
If you want to let xLights manage your controller(s), this is HIGHLY recommended, in xLights in your controller configuration, 
Set the name to something meaningful
Set the Vendor, Model and Variant to match your controller (i.e Falcon, Model to F16V3 and Variant to Expansion Board + No Serial Port Remotes)
Set the IP address of the controller
Set the Protocol you want to use, DDP/E1.31
Set the Start Universe/ID to 1 (or whatever start Universe/ID you want, they don't have to start at 1)
Set the Channels per Universe to either 512 or 510 (it really doesn't matter which you use)
Check the Auto Layout Models
Check the Auto Size
Check the Full xLights Control
Set the default brightness
Save your settings
 
Once that is configured, you can use the Visualizer to put your models on the ports that you are going to use, make sure you have them assigned in the order that you are going to connect them. (The first time you open the Visualizer you will get an error message, that is to be expected) 

DO NOT assign controller, start channels, or such from the Layout page. Xlights will manage that.
Then Save your Controller settings and your Layout settings. On the Controllers tab, select your controller and then click on the Upload inputs then upload outputs (or just outputs if the inputs are greyed out).
That is it, you do not configure the ports/channels in your controller, xLights will handle that.
Then go to FPP Connect and upload your configuration in your current configuration, you want to set the UDP option to all.
If to err is human, I am more human than most people.

morrydavis

I'm having an issue with ttyACM0 and ttyACM1 FPP gives error can not initialize  genericserial outputs they were working before in 6.3 just installed new image 7.4 probably user error but not sure how to fix so no show tonight

CaptainMurdoch

Quote from: morrydavis on December 30, 2023, 07:51:15 PMI'm having an issue with ttyACM0 and ttyACM1 FPP gives error can not initialize  genericserial outputs they were working before in 6.3 just installed new image 7.4 probably user error but not sure how to fix so no show tonight

Are you actually using the onboard serial or a USB dongle?
-
Chris

Support FPP

+- Recent Topics

Changing FPP firmware by dkulp
July 19, 2024, 06:20:26 PM

Intro to the Octoscroller by dkulp
July 19, 2024, 04:41:13 AM

xCapture Playback Issues by dkulp
July 19, 2024, 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod