News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16427
Latest: digilabpg
New This Month: 21
New This Week: 2
New Today: 1
Stats
Total Posts: 132342
Total Topics: 16406
Most Online Today: 93
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 57
Total: 58

Recent posts

#91
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by madsci1016 - April 03, 2024, 10:33:48 AM
Quote from: Poporacer on April 03, 2024, 10:22:13 AMThere are 2 method of creating Overlay models.
One is to Upload them by checking the Models checkbox and this is not typically recommended unless you have some sort of specialized testing situation or need to create models on a Player that you need to use for sending info to remotes.
The recommended method is to use the Auto Create Models in the Overlay models section.
When you upload the Models in FPP Connect, it will use that info to "override" any models defined automatically and you could have some bad Manual models in there. Can you post a screenshot of your Model overlay section?

Quote from: Poporacer on April 03, 2024, 10:22:13 AMOne is to Upload them by checking the Models checkbox and this is not typically recommended
I'm a little confused if the plan is to not recommend this. I was under the impression development in general was working towards supporting the automatic configuration of FPP and FPP based controllers from xLights for ease of use overall, and pushing models would continue that workflow. Meaning i found a bug we'd want to fix, not a "you were using it wrong" type response. 

I didn't need it for my use right now, I'm just asking to see if my understanding of this philosophy is correct or needs adjusted before i continue to teach new users about xlights and FPP.
#92
It would be highly unlikely that all 4 external port connectors on the controller would have a bad port, especially if it is the same port on all 4.  I would say that you have a bad differential adapter board.  Good luck with the new one.  I had a nearby lightening strike take out 3 of mine with similar issues.  I was able to repair one of them but it was such a PITA, I will just replace the others.
#93
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by Poporacer - April 03, 2024, 10:22:13 AM
There are 2 method of creating Overlay models. 
One is to Upload them by checking the Models checkbox and this is not typically recommended unless you have some sort of specialized testing situation or need to create models on a Player that you need to use for sending info to remotes. 
The recommended method is to use the Auto Create Models in the Overlay models section.
When you upload the Models in FPP Connect, it will use that info to "override" any models defined automatically and you could have some bad Manual models in there. Can you post a screenshot of your Model overlay section?
#94
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by madsci1016 - April 03, 2024, 08:57:06 AM
Quote from: CaptainMurdoch on April 03, 2024, 08:24:36 AMThe file /home/fpp/media/config/model-overlays.json contains the models.  If you attach it here I'll take a look and see if I can reproduce the issue.  You can download it directly from your FPP instance by hitting http://your_fpp_ip/api/configfile/model-overlays.json
_bad is the one that xlights FPP connect uploaded
_good is the manual string one. 
https://drive.google.com/file/d/18iaJTagiieuh9E36tw9emBDrGy2icrWD/view?usp=drive_link 
#95
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by CaptainMurdoch - April 03, 2024, 08:24:36 AM
The file /home/fpp/media/config/model-overlays.json contains the models.  If you attach it here I'll take a look and see if I can reproduce the issue.  You can download it directly from your FPP instance by hitting http://your_fpp_ip/api/configfile/model-overlays.json
#96
Quote from: tbone321 on April 02, 2024, 05:33:55 PMI would ignore the visualizer for now and set it manually as a standard remote and try it that way.  You may also try a different cable between the controller and the board.  Did you also try both ports on the remote board.  A bent pin or a bad cable can also cause this issue.  It could also be a bad connection on the boards communication chip and there's not much you can do about that.
Thanks.  I have tried a different cat5 cable, same results.  Set rx board to standard and same results.  The result is the same no matter what RJ45 port I have the cable plugged into on the K16A-B.......The first port on the RX board (which would be port 17, 21, 25 or 29 depending on which RJ45 jack I am plugged into on the K16) will not light up the pixel string.  Ports 2, 3 and 4 on the rx board all work all the time.  I have ordered another rx board from Kulp to try.  Either the K16 is not sending data to port 1 on the rx board or the rx board is not processing that data correctly.  Hopefully a new rx board will help determine that.
#97
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by madsci1016 - April 03, 2024, 07:51:05 AM
Quote from: CaptainMurdoch on April 02, 2024, 11:26:21 PMCan you try deleting the model and recreating by hand and then retesting manually with the FPP Command?  Maybe delete all other models to make sure there is nothing else affecting it.  If that doesn't help then we may need to see the configs to try to reproduce.  There isn't much that could affect this that I can think of.
Yes, if i delete the "custom" models that were created by the xLights FPP connect, and create new (generic channel) models with the same name, everything, including MQTT and HA control, works as intended. 

Thats gets me what i need. What can i do to help you debug the issue with xLights pushing a bad model onto FPP? What files would you need exactly? (i'm not familiar with FPP config file structure or debugging it in general, because it's just always worked for the years i've used it, so thanks). 

I'm setting up a micro Dell computer with Proxmox, with VMs including OpenWRT, Home Assistant, FPP, Frigate and a few others to help me teach my Camera AI / HA / FPP automation class at the Florida and California Minis this year. Really happy with how it's turning out, its a little virtual lab space to play with the integrations of all those appliances. OpenWRT runs the virtual network and uses the Dell's wifi card to setup an wifi AP, which the smart plug and pixelstick controller connect to.

 
#98
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by CaptainMurdoch - April 02, 2024, 11:26:21 PM
Can you try deleting the model and recreating by hand and then retesting manually with the FPP Command?  Maybe delete all other models to make sure there is nothing else affecting it.  If that doesn't help then we may need to see the configs to try to reproduce.  There isn't much that could affect this that I can think of.
#99
Falcon Player (FPP) / Re: MQTT with Home Assistant, ...
Last post by madsci1016 - April 02, 2024, 07:06:42 PM
Quote from: CaptainMurdoch on April 02, 2024, 05:00:10 PMWhat happens if you run the "Overlay Model Fill" FPP Command manually on that model?  The channel tester is testing channels directly, but the plugin is using the FPP Command to turn on the model and fill the model with a color.  I'm not seeing how the plugin could be broken unless the command wasn't working for some reason.  Do you perhaps have two pixel overlay models with the same name?
I tried 



And it's the same result, just a few red pixels. 
#100
I would ignore the visualizer for now and set it manually as a standard remote and try it that way.  You may also try a different cable between the controller and the board.  Did you also try both ports on the remote board.  A bent pin or a bad cable can also cause this issue.  It could also be a bad connection on the boards communication chip and there's not much you can do about that.

Support FPP

+- Recent Topics

configuration by morrydavis
Today at 04:34:20 PM

FP 7.5 Crash after approximately 440 loads of the same Playlist, memory full by CaptainMurdoch
Today at 03:48:12 PM

F32v5 Release Date by JonD
Today at 09:14:57 AM

MQTT with Home Assistant, model control only lights up some pixels. by CaptainMurdoch
April 22, 2024, 01:30:45 PM

Looking for a way to "fast forward" a video playlist by Jayl
April 18, 2024, 03:20:31 PM

P9-28 and P9-29 not work by windaube
April 15, 2024, 03:40:34 PM

Resetting or Removing FPP Password (with Windows) by greenreader9
April 14, 2024, 06:21:46 PM

Enclosure for Video Projectors by Scott
April 14, 2024, 12:00:50 PM

Born in the USA by Xmas!
April 13, 2024, 03:25:16 PM

1200w HP Power Supplies by MikeKrebs
April 12, 2024, 08:53:19 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod