News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15649
Latest: zj023
New This Month: 53
New This Week: 0
New Today: 0
Stats
Total Posts: 128339
Total Topics: 15780
Most Online Today: 57
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 22
Total: 25

Remote script issue

Started by mac1321, December 02, 2022, 08:08:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mac1321

Running 6.2  with 1 master and two remotes.  All where fresh new installs this year.  Light show works and my projector on the remote run's videos no problem with my sequence.

The issue I am having is if I use the projector plugin scripts to power on and off the projector, I have no issue.

When I try to use run remote script and put the script name in and the IP address of the remote that has the scripts and the projector attached the script never runs.  So, I am stumped and stuck. 

Any ideas or suggestions?  Below is my lead in and my lead out is just the power off script being run the same way,



darylc

does the script work when you run it directly from the remote?

mac1321

Yea it works fine when run on the remote pi directly.  Just can't trigger it to run from the master now.

Aaron Maue

I know this thread is getting a little stale, but in case you're still checking, here's a possible workaround...

1.  On the remote, create a command preset that fires the script.
2.  Instead of trying to launch a remote script from the player, launch the remote command preset.

I'm not a dev, but I'm thinking it should work the way you're trying to do it.  In the meanwhile, however, maybe this will get you rolling.

jnealand

I had a similar problem trying to turn my static TuneTo on and off.  The scripts worked great if run from the remote, but not when triggered from the master in my leadin and leadout.  The problem is the the command needed a fully qualified script name.  ie.  I had to add .sh after the script name.  Once I changed StaticOn to StaticOn.sh  it worked just like I wanted it to.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

Script/Plug-In Trigger on Data by CaptainMurdoch
Today at 01:41:47 PM

Set Time/Date by Rick
January 29, 2023, 10:09:08 PM

help getting started, next step? by Poporacer
January 28, 2023, 05:10:18 PM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by half.fast
January 28, 2023, 03:19:37 PM

wifi issues on BBB running fpp v6.3 by k6ccc
January 28, 2023, 02:04:23 PM

BBB / FPP sending data to ESP32 WLED by srwmemphis
January 28, 2023, 04:39:02 AM

raspberry PI 3 / PI 4 by mrfix1
January 27, 2023, 07:13:55 AM

Bug in newest release by tbone321
January 26, 2023, 06:14:26 PM

Cannot Connect to F48V4-NS Through Rasberry Pi by Poporacer
January 26, 2023, 03:13:43 PM

new piCaps in the works? by Bwinter
January 26, 2023, 11:25:32 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod