Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15698
Latest: kronescharles
New This Month: 16
New This Week: 2
New Today: 0
Total Posts: 128629
Total Topics: 15828
Most Online Today: 48
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 26
Total: 27

BBB Rev C WIFI Loading Issue when FPP is loaded to the eMMC

Started by WHundley, February 19, 2022, 09:16:29 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've been having an issue with my WIFI loading at boot, it began about 6 months after I built my K32 controller. At first it was intermittently not connecting but then stopped connecting completely (I could easily connect it manually in an FPP command window). What I believe is happening: I have a Rev C BBB and FPP is loaded to the 4GB eMMC, when my controller was first built there wasn't much loaded to the 32GB Micro SD card so (I believe) reading data from the card was fast and everything worked perfectly! As I added files to the storage card (I believe) the read time at boot-up slowed / took longer! I eventually hit a point (where I'd added enough files to the SD card) that the read delay is now high enough (at boot-up) that FPP is timing out on my configured WIFI load which causes an eventual default to the Tethering FPP WIFI load (done near the end of FPPs boot-up). As I said above I can easily go in after FPP boots and manually connect to my WIFI without any issues. It looks like there needs to be additional time allowed for the SD Card read (when it's not the boot source) or the WIFI USB drivers and config files need to live on the BBB eMMC rather than the removable media.

Update: I removed all my media and sequence files from the SD card bringing it down to 14% space utilization and the issue persists.
I dumped the entire install, reset the BBB back to factory, formatted the SD and loaded a new FPP image. The BBB is back in the controller and fully reloaded and the issue is unchanged. The Tethered FPP default loads and is visible in my laptop WIFI list but FPP just won't connect to my wireless router (I can manually connect it via command line as I did before the rebuild)


Issue resolved: I allowed the BBB to boot-up, I connected to the Tethered FPP WIFI then logged into the BBB via PuTTY. Using connmanctl I manually attach the BBB to my WIFI (I lost my PuTTY connection). I connected to my WIFI and opened the FPP GUI in my web browser. Then went to the Interface Settings under Network Configuration, selected wlan0 in my interface name box and clicked the Create Persistent Names button! Acknowledge the warning message - yes I wanted to do this.

Every Reboot of my BBB after doing this results in a good connection to my WIFI!

(My configuration: Rev C BBB on a Kulp K32A-B running the current OS and FPP installs, using an EDUP USB WIFI adapter also from Kulplights. My BBB has a static IP config which connects to a WIFI router that's not connected to the internet )

Update: I changed my BBB usb WIFI adapter (I went from a 2dB gain antenna to a 5dB) this meant I needed to redo the "Create Persistent Name" process, I deleted the old Persistent Name in FPP and went through the steps to manually connect the BBB to my router. What I ran into was the IP wasn't updating on my K32 display after performing the connect command, to remedy this I had to unplug my wifi router then plug it back in to get the IP to update on the BBB display. I could then do the Create Persistent Name in FPP.

root@FPP:~# connmanctl 
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
Lightshow_2g         wifi_4401bbac0a5e_4c6967687473686f775f3267_managed_none
WavHomeSys           wifi_4401bbac0a5e_576176486f6d65537973_managed_psk
connmanctl> agent on
Agent registered
connmanctl> connect wifi_4401bbac0a5e_4c6967687473686f775f3267_managed_none
Connected wifi_4401bbac0a5e_4c6967687473686f775f3267_managed_none
connmanctl> quit


I have a K16A-B with BBBVC and a EDUP wifi antenna, all from Kulp Lights. I cant seem to get the BBBvc to connect to my wifi. When i go to FPP i only have the option to use eth0. How can i fix this issue?

Support FPP

+- Recent Topics

Libre SBC with oled by mel4853
March 24, 2023, 04:04:06 PM

K8-Pi - Random Pixels on by cybercop23
March 24, 2023, 10:44:49 AM

Limitations on Video file size? by Jayl
March 23, 2023, 11:06:14 AM

FPP 7 Kubernetes Error by Jlwright325
March 22, 2023, 11:11:59 AM

FPP Install on Raspberry Pi Zero W by k6ccc
March 21, 2023, 05:53:50 PM

FPP install script on Ubuntu, no video by AlexanderMedia
March 21, 2023, 09:37:23 AM

DMX to pneumatic solenoid by JerryPlak
March 20, 2023, 01:03:53 PM

F16v3 External Power Connector by darylc
March 16, 2023, 05:25:46 PM

FPP on PC HDMI Output by AlexanderMedia
March 15, 2023, 01:17:55 PM

Orange Pi One and external DS3231 RTC on rtc1 by Arti G
March 13, 2023, 09:29:28 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod