Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16443
Latest: zakkwillow
New This Month: 14
New This Week: 2
New Today: 1
Total Posts: 132549
Total Topics: 16433
Most Online Today: 69
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 63
Total: 63

Only some lights come on from each of 8 ports, even in test mode

Started by Laser Falcon, July 20, 2023, 12:29:23 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Laser Falcon

I am using my Megatree controller to control some special props in a musical theater play.  They are not behaving the way they normally due for my Christmas light setup.
I am using the first eight ports of my controller with one universe for each port. E31 setup is 510 per port. String Port configuration is 170 pixel count per port. When I go to test mode, only the first 85 pixels light up per port. If I change the port pixel count to 171 instead of 170, all the lights on my test string (200) come on.  This is just one of dozens of setups I have tried to get these lights working buy this should be the basic setup that works.  My actual props that I built have 129 pixels. One on each port.  Any thoughts on what I am doing wrong? After 5 years I thought I understood all of this but clearly I don't.  My play director is getting impatient with me because I promised her these exciting props for the show.


Universes are limited to 512 channels.  170 lights times 3 RGB channels = 510.  Should be fine at 170 lights.

Some print screens of your configuration would be helpful.  Your Falcon E131 tab and the Output Settings\Pixels tab especially.   Make sure on the Output Settings\Pixel tab that each port has "Pixel Count" set to 129 if each port has 129 lights.


We will need a bit more information than this but I will say is not to depend on built in test functions.  They are far from reliable as far as configuration goes.  The fact that the controller is lighting any of them shows that the lights are connected properly.  When I test I use test sequences that I create and in many cases, I will define the test prop to 1 less node than it actually has to make sure that the configuration on the controller is correct.  What controller are you using as your Megatree controller?


Tbone321 makes a really good point.  Test functions have been iffy on older firmware versions.  If your Falcon F16v3 firmware is lower than 2.59, there could be an issue with the test function itself.  If you are running an older F16v3 firmware version you should consider upgrading.  Otherwise, a test sequence is a good idea as well.

Laser Falcon

The problem was first observed when I was trying to use the 129 pixel "flower" models I built for the play.  I started out using my normal, original setup where I had each port configured for 150 pixels for my Megatree.  Since the flowers only had 129 pixels, I thought everything should work fine without making any configuration changes.  Unfortunately only the first 65 pixels on each flower (one each of the first eight ports) would come on whether I was running a sequence or trying to trouble shoot.  I tried so many things I can't express all of the various results I had.  That is why I started with this post to show that the problem "appears" to be from my Falcon V3, version 1.1, setup rather than my FPP or my Xlights configuration.  If I can't rely on the test function that is problematic. I have no doubt I am doing something wrong since each port behaves the same way so I doubt if it is hardware.
By the way when I changed the pixel count to 100 (used 100 instead of 129 since I am testing with a string at home) as suggested by JonD, and used the test option on the Falcon V3, only 15 pixels of the string light up.
My firmware version is 2.55


Sounds like you have made a lot of changes to resolve this, and hard to tell what is going on.  Using E1.31 several things need to line up for it to work.  A print screen of the xlights prop configuration, and Falcon Status,E1.31,Output Settings\Pixel tabs would be helpful to resolve this for you. 

Laser Falcon

Well I have good news.  JonD hit it on the head when he said to upgrade to 2.59.  I did that, changed everything back to the configuration I have been using for 5 years and everything works perfect.  It tests out as expected from the controller, the FPP, and xlights.  Most importantly, the sequences appear to be showing correctly, at least the best I can tell with test strings hooked up on the floor at home.  I will know for sure tomorrow when I take everything back to the theater and hook it up to the flower models.  Nothing like cutting it close.  The show opens tomorrow.
Thanks for you quick responses.  They were a life saver since a lot of people were counting on this major feature for our SpongeBob The Musical set.


Glad you were able to resolve.  Good Luck with the show!


Quote from: Laser Falcon on July 21, 2023, 01:29:13 AMIt tests out as expected from the controlle
I wouldn't rely on the testing from the controller, there are still some bugs in the testing function in 2.59.
If to err is human, I am more human than most people.


Quote from: Poporacer on July 21, 2023, 02:41:47 PMI wouldn't rely on the testing from the controller, there are still some bugs in the testing function in 2.59.
Absolutely...  You should never fully trust any on-board test button, but it is a pretty handy tool not to use at all.  I own over a dozen v3 series controllers and use the test feature all the time.  It has always worked well for me.  With that said, anytime a test result is not making any sense, you should always try to confirm the results another way.

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod