LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16480
Latest: tcooper
New This Month: 12
New This Week: 1
New Today: 0
Total Posts: 132763
Total Topics: 16481
Most Online Today: 229
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 229
Total: 229

Kulp K8Pi Issues

Started by JonD, September 23, 2023, 09:00:10 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


The frame rate issues when these are attached to a Pi4 appear to still exist.  F-Tester shows they drop lights constantly.  I have found some light strings you can notice the drops and other lights you don't, but F-Tester shows them dropping consistently regardless of the light string used.  I did grab a Pi3b+ and replaced the Pi4.  When attached to the Pi3b+, F-Tester showed a flawless test and not a single light appeared to be dropped.  No frame rate errors on a Pi3b+, constant errors on a Pi4.  Easily recreated on all four controllers.

Originally, I was having an issue with one of the 4 controllers I purchased.  It did not appear to boot when powered from the K8Pi board, but trying to re-create the problem consistently did not seem to be possible.  When I decided to try a Pi3b+, this is the first board I went to, and the problem board booted right up.  At first I could not get the Pi3b+ to fail.  I went ahead and installed a Pi3b+ on the other 3 controllers (4 total) and they all seemed to be working fine.  That was until an update or two ago.  The upgrade on the FPP P4 master went fine.  I then upgraded the four Kulp K8Pi controllers from the multi-sync upgrade.  It turned every single Kulp into a brick.  No Kulp logo at power on.  I installed a fresh copy of FPP 7.1 2023-08 and that appeared to resolve short term.  They were displaying QR Scan code for the Wifi hotspot.  I powered off to move the controller next to an ethernet jack to give it an IP and it would not boot back up.  I had to re-image the SD card again.  If I assign the ethernet port a manual IP or have the controller plugged into an ethernet jack and get a DHCP address, and process the initial setup it appears to reboot fine after that.  I am not sure the K8Pi power issue was ever a thing at this point.  I suspect it could have been the SD image was corrupting.  I am using 3 different SD card types (two of which Daniel Kulp recommends) and fairly certain this is not an SD card issue.

Finally after a fresh FPP 7.1 2023-08 image installation, if I try to change the any Kulp K8pi controllers from 7.1 to master.  I get the following error "FPPD not found.  Rebuild required."   (I would upload the error, but the forum file upload appears to be broken).  If you hit the build button it turns the controller into a brick.

Most of these issues appear to be re-creatable, and unrelated to my personal network or settings.  I don't plan to use these in production, so I am not needing them fixed, but thought I would post what I have been running into.


My K8Pi on a 3B+ is not having any problems. It gets all the latest Master updates.
I stopped using the Pi4 because I was seeing those dropouts, visibly and on F-tester.

Version Info   
FPP Version:   7.x-master-259-ga9658881
Platform:   Raspberry Pi (Pi 3 Model B+)
FPP OS Build:   v2023-07
OS Version:   Raspbian GNU/Linux 11 (bullseye)
Hardware Serial Number:   0000000057f6d9a7
Kernel Version:   6.1.21-v7+
System Boot Time:   2023-09-07 19:38:41
fppd Uptime:   22:55:16
Long time Falcon, FPP and xLights user


Are you guys using DDP or E131?


I have them all running again finally.  I was installing a fresh FPP 7.1 2023-08 image, doing the initial setup, and rebooting.  Once everything was where it needed to be, I was updating to the latest 7.1, and then switching it from 7.1 to Master.  That would give the error "FPPD not found.  Rebuild required."  If I installed a fresh FPP 7.1 2023-08 image, did the initial setup, and switched from 7.1 to master before any upgrades, I did not get the error.  I am beyond this problem now.

I tried to find the magic combination that was causing the other error, and could not create it consistently, however in the process I had another controller not boot.  No matter how many times I refreshed a new image, or which SD card I installed, I never saw the Kulp logo.  I began to wonder if some of the problems are the SD extender I am using.  The Kulp K8pi places the Pi underneath the board and the SD card slot is impossible to get to.  I bought some SD card extenders ( so that I could replace the card if needed.  Sure enough I re-seated the extender and wiggled the cable a bit and it started to boot again.  I bought a different brand of extender off of Amazon and will give that a try to see if I get different results.  I have of course swapped extender cables, and tried removing the cable all together troubleshooting this issue, but I did not account that the SD card was corrupting in the process, and could have been using a corrupt SD card image when swapping.


Quote from: breese on September 24, 2023, 05:42:36 AMAre you guys using DDP or E131?
I was using DDP when the multi-sync upgrade bricked them in the first place, but there was no configuration on them with my rebuild issues.  They only had a hostname and IP address from the initial setup.  I had not been able to have xlights resend them their configuration, and nothing was configured at the port level.


I asked because all 3 of my Pi's (2-pi4 1-p3B+) all had Bytes Received Errors with DDP.
When I switched everything over to E131 the issues went away!


Quote from: breese on September 24, 2023, 09:16:36 AMI asked because all 3 of my Pi's (2-pi4 1-p3B+) all had Bytes Received Errors with DDP.
When I switched everything over to E131 the issues went away!
I get that error all the time as well, but was ignoring it for now.

Support FPP

+- Recent Topics

Changing FPP firmware by dkulp
July 19, 2024, 06:20:26 PM

Intro to the Octoscroller by dkulp
July 19, 2024, 04:41:13 AM

xCapture Playback Issues by dkulp
July 19, 2024, 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod