LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16423
Latest: mezzmosis
New This Month: 16
New This Week: 1
New Today: 0
Total Posts: 132321
Total Topics: 16403
Most Online Today: 91
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 50
Total: 54

FPP on Pi not sending anything to Renard SS8

Started by kdoyon, October 24, 2017, 10:34:42 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi everyone,

I have recently jumped into this hobby, and I am at a sticking point.

I am able to use vixen on my computer to send data to a Renard SS8, and the lights hooked up to it will light up. I am connecting the computer to the Renard with a USB to RS485 adapter. I did have to go in to display setup and tell Vixen that the Renard controller was on COM 4 instead of COM 3 like it first thought. Then everything works fine.

However, when I hooked up the Renard to my Raspberry Pi B with FPP running, I cannot get the lights to light. I have tried both the channel test and sequence test (uploaded a fseq file exported from vixen. The same file that works when the Renard is directly connected to the computer running Vixen.

I have attached a picture of how I have the Renard controller set up in Channel Outputs. The only thing I noticed that I don't understand is that the only choice for port was ttyAMA0. Not sure what that means or if it is what I need.

Any help would be appreciated.




Was the Renard USB dongle plugged in when the Pi booted? Many USB devices need to be sensed at boot to be properly listed by their tty address.

Long time Falcon, FPP and xLights user


Darn. I was hoping that might be it. I rebooted and tried it again. Nothing. Then I did a full shutdown of the Pi and started it back up. Nothing.

Any other ideas?

Sent from my iPhone using Tapatalk


other than varying the baud rate or Com parameters, no.

There are others here who do Renard (I don't) who may know more.
Long time Falcon, FPP and xLights user


Thanks for trying!

Sent from my iPhone using Tapatalk


I use FPP to drive 32 channels of Renard.  On my Channel Outputs page the I have the port set to ttyUSB0.  You might try that. 


Quote from: dakingus on November 04, 2017, 05:28:05 PM

I use FPP to drive 32 channels of Renard.  On my Channel Outputs page the I have the port set to ttyUSB0.  You might try that.

This is probably it.  ttyAMA0 is the onboard serial port on the Pi, so you only want ttyAMA0 if you are using something like a PiCap to convert that to RS-485.

For USB dongles, you want the ttyUSB0, ttyUSB1, etc. devices.


I used ttyUSB0 for my renard going through a USB dongle.
But I also had to build a small crossover board to go between the dongle & Renard.
Then I was able to get lights :)

Support FPP

+- Recent Topics

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod