News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16446
Latest: josh19002
New This Month: 17
New This Week: 3
New Today: 1
Stats
Total Posts: 132570
Total Topics: 16437
Most Online Today: 175
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 132
Total: 132

Firrmware update on F16V3

Started by hoogieburner, November 06, 2022, 03:28:39 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

hoogieburner

Updating my F16V3.....updated the bootloader and now it flashes bootloader v2.  i cannot factory reset it and not sure where to go from here.....
My other F16V3 took the update just fine.
Thanks in advance for the feedback!

JonD

I would try to update it again.  Seems like you can not update the bootloader and firmware at the same time.  Remove the firmware from the SD card when updating the Bootloader, and vice versa.

Factory Reset (Needed when updating from 2.0x )
1) Save settings to file to reload after update.
2) Power Down
3) Hold in Select button (Next to Right Button)
4) Power up while holding button. The controller should display message stating a reset is occurring.

Replacing bootloader. (These steps are only done once)
1) Place BootloaderUpdater_v1.00.fal on a MicroSD card (32GB or Smaller, formatted Fat32).
2) Place MicroSD card into controller and apply power.
3) The application will be loaded and the screen will prompt to remove sd card and power down then up.
4) Remove SD card.
5) Power Down/up
6) The application will replace bootloader.

Updating Firmware (These steps taken for each firmware update)
1) Place .fl2 file MicroSd card
2) Power Down/Up
3) The firmware will install
4) Remove card when finished and power down/up.
5) Controller will boot

darylc

If its flashing bootloader v2, then this step did not work and needs to be done again:

Updating Firmware (These steps taken for each firmware update)
1) Place .fl2 file MicroSd card
2) Power Down/Up
3) The firmware will install
4) Remove card when finished and power down/up.
5) Controller will boot

hoogieburner

Thanks so much for replying,
So i did get through to downloading the bootloader....but now it just flashes Bootloader v2
i have tried to reset it again by powering down and bringing back up while holding select but if I let it go once the LED Lights flash it reverts to flashing bootloader v2.  If i keep holding the select button it blinks resetting controller. 

JonD

#4
Sounds like the bootloader is updating.  Now, delete the file "BootloaderUpdater_v1.00.fal" from the SD card and replace it with the firmware "F16v3_2_59.fl2" file.  (Assuming you are upgrading to firmware 2.59)  The Bootloader file can not be on the SD card, if you want to upload the firmware. 

Updating Firmware (These steps taken for each firmware update)
1) DELETE BootloaderUpdate_V1.00,.fal FILE FROM MicroSD CARD!!!! (From step above)
2) Place .fl2 file MicroSd card
3) Power Down/Up
4) The firmware will install
5) Remove card when finished and power down/up.
6) Controller will boot

hoogieburner

Thanks Jon for the reply.
I have removed the Bootloader from the Card and put the fl2 file alone on it.  
I have also redownloaded it on the off chance there was some corruption to the file.
The Bootloader v2 will keep blinking for hours if i left it on......this is the second controller that i am updating and the first went without a hitch.
Is there a reason why it will not allow me to do a factory reset that you know of?
I will try again ASAP and let you know.

JonD

Not that I know of.  I have seen firmware updates go bad, but typically just following the directions again will resolve the issue.

What firmware was you on, and what are you trying to go to?  Have you tried a different SD card?

JonD

#7
Confirming you are unplugging the controller A/C.  Holding down the Select button and not letting go.  While holding in the select button, plugin the power, and keep holding the select button until it says "reset".  (Usually 5-10 seconds and then wait 30-60 seconds)

You cannot view this attachment.



I have seen when coming from an older 2.0 firmware version it is better to upgrade to 2.55 first, and then upgrade to 2.59 once upgraded to 2.55
https://www.pixelcontroller.com/firmware/f16v3/F16V3_2_55.zip

hoogieburner

Ok.
Attempt One:
A different 32GB MicroSD card is loaded with Build 2.55
Power is Off
Inserted Card and powered up
And &%$# it worked!
Powered up and down and we have success!
Installed 2.59 without a hickup
I do find it odd that one of my F16V3 controllers had no problem to go direct to 2.59 and the other did.  They were ordered at the same time so I would think they would be equal......but I ramble.
Thank you very much for your help.  Its guys like you that keep the light show going.

JonD

Glad you are back in business! :)

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod