News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16476
Latest: jbhubert
New This Month: 8
New This Week: 5
New Today: 2
Stats
Total Posts: 132724
Total Topics: 16475
Most Online Today: 114
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 76
Total: 77

F48v4 upgrade firmware issue

Started by mcsketchy, August 15, 2023, 10:45:51 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mcsketchy

Hi. I've attempted to upgrade my F48v4 to the latest firmware and have not been successful. I first attempted via the webpage, but that always ended up hanging, so I switched to SD. The files get copied and I'm instructed to pull the card out, yet nothing happens after the reboot. The OLED shows the build is still 17. Curiously, the webpage no longer displays the notice that an upgrade is available. Could the build showing be inaccurate? If not, what could I be doing wrong? Also, I've reset the device a few times and tried files for both build 21 and 26 and got the same result.  

Thanks in advance for any help.

JonD

Seems like Build 21 is a bad image.  You might try to reset and downgrade to build 25.  If successful you should be able to upgrade to 26 from 25

mcsketchy

Still no luck; the build is displayed at 17 no matter what firmware I upload. Each time I have reset the setting, loaded the SD, and removed the SD when prompted. After the reboot, the system boots up immediately, so it doesn't seem like anything changed. But, each time I upload the new firmware file, the name changes in the controller information section. For example,
  • Falcon_48_V4_Firmware_18.fl3 (Build 25) changes name to Falcon_F48V4_04E2
  • Falcon_48_V4_Firmware_23.fl3 (Build 25) changes name to Falcon_F48V4_3BCD
  • Falcon_48_V4_Firmware_25.fl3 (Build 26) changes name to Falcon_F48V4_D408

Is there a way to check the firmware version rather than just the build?

bloojoop

what size is the sd card?  what file system is it formated with... I believe it support cards up to 32gb and fat32 only.  If the sd card is formatted as exfat that may be the issue. 
--Ron A.

mcsketchy

sd is 32gb and formatted as fat32.  I formatted with macOS disc utility but it does format as fat32

mcsketchy

I've also tried updating multiple times with the web interface (it isn't hanging now). the same thing happens: file upload successfully, reboot, immediately boots to main screen with build 17 displayed. 

bloojoop

sorry mate, out of ideas now... I've updated about 20-25 of them both online and sd card method and have not run into this problem ???  Although I should say, the firmware .fl3 file should be the only file on the sd card... no hidden files or anything else.
--Ron A.

mcsketchy

Quote from: bloojoop on August 15, 2023, 09:44:51 PMsorry mate, out of ideas now.
thank you for helping. I appreciate your time. 

JonD

#8
I am out of suggestions as well.  Make sure you have tried using another SD card to rule out a bad card issue.  Make sure you are loading the correct firmware.  Trying to load F48v4 firmware to a F16v4 controller or vice versa would give you the above results.  Almost sounds like the board is not resetting to factory defaults.  What steps are you using to factory reset?

I would reach out to Falcon support if your still having problems.  https://pixelcontroller.com/store/contact-us

mcsketchy

OK I have some more helpful information. I switched to a PC to see if that made a difference. Same result with the SD card, but when I tried to upload from the web interface, the message "Firmware not valid for this board" popped up. 

I purchased by F48v4 in July, 2021 and I've download all files from here: https://github.com/Pixelcontroller/f16v4_issues/tree/master/F48V4. Below are the files I've tried.  Any suggestions now?

Falcon_48_V4_Firmware_16.fl3
Falcon_48_V4_Firmware_18.fl3
Falcon_48_V4_Firmware_19.fl3
Falcon_48_V4_Firmware_20.fl3
Falcon_48_V4_Firmware_21.fl3
Falcon_48_V4_Firmware_23.fl3
Falcon_48_V4_Firmware_24.fl3
Falcon_48_V4_Firmware_25.fl3
Falcon_48_V4_Firmware_26.fl3


JonD

#10
Quote from: mcsketchy on August 16, 2023, 04:17:23 PMthe message "Firmware not valid for this board" popped up.
What the controller is doing and the above message does go along with trying to apply the wrong firmware version, but the filename you listed looks correct for the controller model.  Could the firmware be corrupting some how?  Sounds like you have tried downloading from a different device, using a different SD card though.

You could try unplugging the controller from power for 1 minute, push and hold the "select" button on the controller, and while continuing to hold in the "select" button in, plug the controller into a power outlet.  The controller OLED should display "resetting" which at that point you can let go of the "select" button.  Let the controller rest giving it time to think for 3-4 minutes, and then if nothing is processing on the OLED screen, unplug from power for 1 minute and power back on.  Let it rest for another 3-4 minutes.  Sometimes it takes a while before the image starts to copy and it might be possible you're not giving it enough time to do its thing.  Do not unplug the controller if it looks like it is copying files.

If that does not resolve I would reach out to Falcon support. 

mcsketchy


Quote from: JonD on August 17, 2023, 06:28:53 AMIf that does not resolve I would reach out to Falcon support
Will do.  I appreciate your help and time.  



Support FPP

+- Recent Topics

FPP led Panel Troubleshooting. by jbhubert
Today at 05:49:15 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

SMPTE timecode by k6ccc
July 11, 2024, 10:36:03 AM

Matrix panels go full while on every restart by k6ccc
July 11, 2024, 08:17:58 AM

output controller by MikeKrebs
July 10, 2024, 10:31:28 PM

Multiple text effects cause re-render by breese
July 09, 2024, 06:19:48 AM

Cannot change serial settings for Renard by jeff.ott
July 08, 2024, 09:11:47 PM

7.5 wlan ARP issue? by peterjp
July 05, 2024, 11:44:49 PM

FPPv7.5 octoscoller error by dkulp
July 05, 2024, 10:44:41 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod