News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16476
Latest: jbhubert
New This Month: 8
New This Week: 5
New Today: 2
Stats
Total Posts: 132727
Total Topics: 16475
Most Online Today: 114
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 69
Total: 69

FPP channel mapping issue

Started by Chicken, November 18, 2023, 07:19:43 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Chicken

This was a strange one and looking for some guidance.   We run 5 falcon controllers and an FPP to run the show on.  Yesterday I was working on setting up some more of the display elements and did display testing from the FPP and noticed a big chunk of the display was not lining up to the same color at the same time as the rest of the display.  I then changed it to all red and the first two controllers worth of pixels were red but the other three controllers were green.  I was really confused so I ran test mode at the falcons and they were all fine.  I then went back to FPP and tested by the model in red and everything was fine across all 5 controllers but the second I try to do FPP display testing across the entire display things go south again.  

At this point I was really scratching my head so figured let me try a sequence to see if that worked.  That's where things went even further south.  All of the display items on controllers 3-5 (order they are listed in xlights) were not just red vs green flipped but I was getting blue and gold colors showing up as well.   I then remembered I added a two channel dmx ac dimmer to the 3rd controller (falcon f48v4) the day before to turn off a wire frame element we have out at a far part of the display.   It seems that having a 2 channel controller is messing up the channel counts and alignment in the FPP.  

It seems to be FPP related as if I play a sequence right from xlights it works fine but when I upload that sequence to FPP and play it, things are all wrong.  I ended up deleting the two channel dmx from xlights, reuploading all the controller configs, rerendering the sequence and uploading to FPP and it's working fine again.  Any thoughts on what happened and how I can get this dmx controller working and not messing up the FPP?  Thanks 

Chicken

Forgot to include version info.  We were running xlights 2023.19 on a MacBook and FPP was running some release of 7.x but while troubleshooting I upgraded to 7.3.4. Thanks 

JonD

If you are using FPP connect, you may need to select "UDP Out" to "All" to upload new channel information to FPP.

Chicken

I have it set to all by default.  Thanks. 

JonD

If xlights is auto-configuring the Falcon controllers and you add channels... you may have to upload the new channel information to ALL the Falcon controllers (not just the one you changed), and FPP connect the new channel information to the FPP player. 

A print screen of your xlights controller config, Falcon Output Setting/Pixel (and Output Setting/Serial if in use),  FPP Input/Output Setup\Channel Input, and FPP Input/Output Setup\Channel output settings would be helpful.

Poporacer

Quote from: Chicken on November 18, 2023, 07:19:43 AMand did display testing from the FPP and noticed a big chunk of the display was not lining up to the same color at the same time as the rest of the display.
Did you notice the big warning message on the FPP testing page telling you that this might happen?
You cannot view this attachment.

Quote from: Chicken on November 18, 2023, 07:19:43 AMAny thoughts on what happened and how I can get this dmx controller working and not messing up the FPP?
After adding the DMX controller, you have to re-upload the configs to all of your controllers and to FPP as well. You will also need to re-render any sequences and save (in that order) before uploading them to FPP
If to err is human, I am more human than most people.

JonD

Quote from: Chicken on November 18, 2023, 07:19:43 AMIt seems to be FPP related as if I play a sequence right from xlights it works fine but when I upload that sequence to FPP and play it, things are all wrong.
I assumed you had already re-rendered everything, since it was working directly from xlights, but that would need done if you haven't.  If you add channels and don't re-render ALL your songs, I have seen Falcon controllers get wacky when wrong channel information has been sent to them.  You may need to power cycle the controllers if you accidentally send them bad channel information.  They will usually recover on their own, but I have had to power cycle on rare occasions.

Chicken

I had uploaded everything to every controller and the FPP.  I went so far as I deleted all the the config off the controllers besides the network settings and the same thing on the FPP. When I uploaded again to the controllers and FPP it had the same problem.  I'll post some config info later today when I am on the xlights laptop.  Thanks 

JonD

Based on your postings it sounds like the xlights, falcon, and/or fpp channels are not in sync for some reason.  I have seen others post similar issues and it was typically a typo in the channel configuration on one side or another.  If you post your configs we will have a better idea how you have it setup and where the issue might be.

jnealand

I have learned to always, and I mean ALWAYS, use a sequence when setting up color orders snf connection directions.  Display testing from FPP is just not reliable. Once everything is powered and connected to the show network.  I run 5 sequences to let me make sure all the settings are correct.  One each for all red, all green, all blue, bars right, and bars left.  If all those work I feel like the settings are all correct except when I can't count or I let my fat fingerd do touch typing.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

K-State Fan

I do similar to Jim. I have one sequence the is 30 seconds of red, green, blue and white and one sequence that is rgb bars right, up, left and down. I run these after I get everything set up to verify I have everything hooked up and programed correctly.  The white is to check for any power issues.

Support FPP

+- Recent Topics

FPP led Panel Troubleshooting. by Poporacer
Today at 09:29:56 AM

output controller by JonD
Today at 09:29:07 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

SMPTE timecode by k6ccc
July 11, 2024, 10:36:03 AM

Matrix panels go full while on every restart by k6ccc
July 11, 2024, 08:17:58 AM

Multiple text effects cause re-render by breese
July 09, 2024, 06:19:48 AM

Cannot change serial settings for Renard by jeff.ott
July 08, 2024, 09:11:47 PM

7.5 wlan ARP issue? by peterjp
July 05, 2024, 11:44:49 PM

FPPv7.5 octoscoller error by dkulp
July 05, 2024, 10:44:41 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod