News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15526
Latest: stooge
New This Month: 34
New This Week: 22
New Today: 0
Stats
Total Posts: 127420
Total Topics: 15642
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 48
Total: 55

Falcon 4 String Smart Differential Receiver not working as expected

Started by MitchellRGB, October 06, 2022, 11:13:25 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

MitchellRGB

Hello.  I am hoping someone might have an idea of what I can try next to solve my issue. I have a K8-PB running FPP v5.3.1 and 2 Falcon 4 String Smart Differential Receiver Boards v2.01 Black. I am not sure if I have the smart receivers configured correctly or if perhaps something else in FPP is not configured correctly. If I press the Test button on both Smart Receivers, all pixels respond and work as expected. When I send commands from FPP to the smart receivers, only 9A and 12A work correctly. The pixels on 10A, 11A, 9B, 10B, and 11B flash and flicker or do not receive commands (they stay white). At first, I thought it was bad wiring or a voltage issue. To test this I plugged the pixels that were not working correctly (10A, 11A, 9B, 10B, and 11B) into the ports that were working correctly (9A and 12A) one at a time, and all the strings worked as expected when plugged into 9A or 12A when receiving commands through FPP. This leads me to believe I have something configured wrong. Maybe in FPP or the smart receivers? Any help is appreciated, I am not sure where to go from here.

Smart Receivers
You cannot view this attachment.
FPP Channel Outputs for Smart Receivers
You cannot view this attachment.

darylc

Try replacing the network cables, each port on the receivers corresponds to a pair in the cable.

bloojoop

The new black v2.01 receivers have a different processor on them and responds to the timing signals differently when daisy chaining boards... Specifically any board other than A boards likely will not respond as expected.  I noted that you said you had flickering on the A board too but that may be different issue??? anyway, to use the new v2.01 black boards, you will need to be on an up to date version of fpp where the timing signals were adjusted to account for the new boards.  I recommend 6.1.1 at this time. 
--Ron A.

MitchellRGB

Quote from: bloojoop on October 07, 2022, 01:37:51 AMThe new black v2.01 receivers have a different processor on them and responds to the timing signals differently when daisy chaining boards... Specifically any board other than A boards likely will not respond as expected.  I noted that you said you had flickering on the A board too but that may be different issue??? anyway, to use the new v2.01 black boards, you will need to be on an up to date version of fpp where the timing signals were adjusted to account for the new boards.  I recommend 6.1.1 at this time.
Thanks, I didn't update FPP because the lights were not working, but I will do that now. Is A board the first board in the chain or just which board is set to A?

JonD

With the Falcon's it does not matter which order they are in.  You can chain them ABCDEF or FEDCBA, It only matters that you do not have two boards in the same chain set to the same letter.  Only the last one in the chain should be terminated, regardless of what letter it is set to.  Any SR located behind the first termination will not get any data.  Suspect it would be the same with the black ones, but don't know that for certain.

MitchellRGB

Quote from: darylc on October 07, 2022, 12:54:35 AMTry replacing the network cables, each port on the receivers corresponds to a pair in the cable.
This fixed it. I goofed on one end of a patch cable I made.

Support FPP

+- Recent Topics

FPP Connect Limiting Uploads to 16V4 by drpiotro
Today at 06:28:01 PM

Falcon V4 Player by drpiotro
Today at 05:29:09 PM

f16v4 wont play in Player or Master Mode by Poporacer
Today at 05:07:37 PM

FPP 6.2 ColorLight Issues by dennismccreery
Today at 05:06:39 PM

snmpd interference with FPP by Setarcos
Today at 03:55:29 PM

FPP v6.2 Beaglebone Black/Green WiFi at startup by egenoup
Today at 03:46:11 PM

I can't get FPP to work with F16v4 by aquinones3
Today at 03:08:26 PM

K8-PB does not recognize SB Play 3 by Poporacer
Today at 01:58:46 PM

K40D-PB by dkulp
Today at 01:04:36 PM

Text inverted by dreiman
Today at 12:44:05 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod