News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15659
Latest: PaulDzRGB
New This Month: 9
New This Week: 3
New Today: 1
Stats
Total Posts: 128431
Total Topics: 15791
Most Online Today: 48
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 28
Total: 34

FM Transmitter issue

Started by Kensington Graves, November 25, 2022, 07:16:41 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Kensington Graves

I came acros an odd problem last night while trying to deploy a Signstek ST-05B on my master FPP.  Heretofore, I used the VAST FMT-212 without issue.

My setup: FPP 5.4.1 running on a BBB with a SB Play! USB soundboard.  I know. I should upgrade FPP.  I haven't wanted to mess with anything while getting the kinks worked out this year.

FPP recognizes the Soundblaster.  The Soundblaster tests good—it drives a directly attached speaker when a sequence is played.

When the VAST transmitter is reconnected, it works fine.

Symptoms of the problem.

0. Si473/VAST FMT212 plugin is installed.  I don't think this is relevant, but I mention it just in case.

1. If the Signstek transmitter is attached to the SB Play! and is powered on when FPP boots, no sound device is detected.  Either "Dummy" or no devices at all appear in the drop-down box.

2.  If the Signstek transmitter is connected to the SB Play! and is powered off when FPP boots, the SB Play! Is detected.

3.  In case 2, if the Signstek is powered on after boot, the audio device field is wiped clear and no sound device appears in the drop down box under audio/video settings.  I also get an error message of "Could not open audio device - ALSA: Could not open audio device: No such file or directory.

I've posted screen shots of the status page with the error message, and the audio/video tab.

The Apache2-error.log shows:

Thu Nov 24 20:25:18.507712 2022] [php7:notice] [pid 19236] [client 127.0.0.1:53354] Error getting mixer devices!
[Thu Nov 24 20:37:59.929933 2022] [php7:notice] [pid 2348] [client 127.0.0.1:49862] Error getting mixer devices!
[Thu Nov 24 20:44:27.870599 2022] [php7:notice] [pid 2775] [client 127.0.0.1:35664] Error getting mixer devices!
[Thu Nov 24 20:48:16.759941 2022] [php7:notice] [pid 1576] [client 127.0.0.1:36532] Error getting mixer devices!

fppd.log shows nothing unusual.  Just messages related to multi sync and scheduler. 

I suspect that there is some backfeed along the audio input line from the transmitter when it powers on/is on, and that is causing the USB device to reset.  Any thoughts?

rudybuddy

Had the same problem. Had to move my transmitter further away from the SB ( 6' in my case). 

Kensington Graves

Interesting.  Mine is on a 1.5m audio cable.  I'll order a 2m cable and see if that helps.  Thanks, Rudybuddy.

rudybuddy

You might also want to check the transmit power setting, if it's on high (I believe default) will also cause a problem with the SB. The low power setting will allow it to be closer to the SB and still provide plenty of range for your show.

Kensington Graves

The longer cable did the trick.  Thanks again.

k6ccc

Useful to know that the SoundBlaster is that RF sensitive.  I am using a SoundBlaster 3 for my show audio (plugged into a PC, not a FPP instance), but it's about 100 feet from the transmitter.

BTW, you pretty much can't just plug in a 100 foot cable from an audio source to the transmitter and get good audio.  If you need to do something like that, ask me how...  Radio broadcast engineer background comes in handy once in a while.
Using LOR (mostly SuperStar) for all sequencing - using FPP only to drive P5 and P10 panels.
My show website:  http://newburghlights.org

Jim

Kensington Graves

I will cheerfully endure your critique of my system if you make it out my way this year.

Support FPP

+- Recent Topics

Warning/Error: Network incomplete frames hit 250. by JonD
February 06, 2023, 04:10:22 PM

F16V3 with 2 expansion boards at 40 fps MAX PIXELS per output? by tbone321
February 06, 2023, 10:51:55 AM

F48V4-NS at 40 fps using all 48 pixel output ports? by Poporacer
February 06, 2023, 10:27:09 AM

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod