Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16422
Latest: geoffhoops63
New This Month: 15
New This Week: 0
New Today: 0
Total Posts: 132312
Total Topics: 16402
Most Online Today: 88
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 68
Total: 68

F4V3 controller - IP address issues

Started by Keebler, October 16, 2023, 06:46:15 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


So, the only way that I can get the controller to get an IP address is to hold the button at the top left corner. then it will get an IP address, but I can not do anything to set the board up - if I take pressure off the the button (top left corner).
I have FW ver 2.55 (obtained from the web interface) - is there a newer version that possible corrects this issue?

The board is new... I bought it a few years ago, forgot I had it, found it, and thought this is exactly what I need for a new location at my home... however. I am having issues...

a quick search for firmware, takes me to the F16 pages. is the F16 firmware the same as the F4? I wouldn't think so...


Firmware 2.59 is the latest public release.  F16v3 and F4v3 do not use the same file.

Not aware of it correcting any issue like you described.


thank you for the link.
Ill contact David then about this issue - thank you


So, Ive tried unsuccessfully, to update the firmware by sd card.
here are the steps I took

formatted the micro sd card (in this case a 4gb) to fat32
copied the file F4V3_2_59.fl2 to the sd card
placed the sd card (face side right) in the sd card slot
booted the board

nothing happened - went right to the default

tried it as well with the F4V3_BootloaderUpdater_v1.00.fal
expecting to see the remove sd card message

both times
the oled shows
"booting controller"
the falcon icon
then the status screen

it seems to be ignoring the sd card slot


Did you reset your F4v3 first?  Many people skip over that step, but it is important to do that.


Factory Reset (Needed when updating from 2.0x )
1) Save settings to file to reload after update.
2) Power Down
3) Hold in Select button (Next to Right Button)
4) Power up while holding button. The controller should display message stating a reset is occurring.

Replacing bootloader. (These steps are only done once)
1) Place BootloaderUpdater_v1.00.fal on a MicroSD card (32GB or Smaller, formatted Fat32).
2) Place MicroSD card into controller and apply power.
3) The application will be loaded and the screen will prompt to remove sd card and power down then up.
4) Remove SD card.
5) Power Down/up
6) The application will replace bootloader.

Updating Firmware (These steps taken for each firmware update)
1) Place .fl2 file MicroSd card
2) Power Down/Up
3) The firmware will install
4) Remove card when finished and power down/up.
5) Controller will boot


At firmware 2.55 you probably do not need the "F4V3_BootloaderUpdater_v1.00.fal" file.  It is not going to hurt to update it again, but I have had it get in the way and keep the "F4V3_2_59.fl2" file from loading.  Make sure you reset the controller, and then place only the .fl2 file on the card.


The controller completely ignores the SDCARD.

double checked the format (FAT32)
double checked the SDCARD 32gb or smaller
double checked that nothing else is on the SDCARD
double checked the SDCARD is seated properly in the slot

did we not used to have the ability to update the controller via network? I can recall updating several controllers via the network a few years back


I have had them not want to take 2.59 before.  Seems like I downgraded to 2.55 first, and then upgraded to 2.59.  You might try a couple of older firmware versions like 2.55 or 2.58.  If you can get either of those installed, you should be able to upgrade to 2.59 after.

There is the Falcon Update Tool-1.0.exe, but the controller has to be functioning with a valid IP address in order to use it.  I would reach out to David and see what he has to suggest. 

Store Information

Support FPP

+- Recent Topics

P9-28 and P9-29 not work by dkulp
April 14, 2024, 10:55:47 PM

Resetting or Removing FPP Password (with Windows) by greenreader9
April 14, 2024, 06:21:46 PM

Enclosure for Video Projectors by Scott
April 14, 2024, 12:00:50 PM

Born in the USA by Xmas!
April 13, 2024, 03:25:16 PM

1200w HP Power Supplies by MikeKrebs
April 12, 2024, 08:53:19 PM

Colorlight card not responding to FPP by CaptainMurdoch
April 12, 2024, 09:21:54 AM

FPP and WS2812b not work, but work with python script by CaptainMurdoch
April 11, 2024, 03:34:17 PM

Feature Request: An Alexa interface to the FPP? by CaptainMurdoch
April 10, 2024, 05:55:05 PM

Pixel2Servo how to control direction on a continuous free rotation servo by kennylights
April 09, 2024, 01:44:56 PM

Background Image (House) Not Visible In XLights by THERCLAN
April 05, 2024, 07:44:36 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod