Falcon Christmas

Falcon Christmas => F4V2 4-Port E131 controller => Topic started by: Pineapple on April 04, 2019, 11:40:56 PM

Title: trouble using differential receiver board on serial port
Post by: Pineapple on April 04, 2019, 11:40:56 PM
i am using an f4v3 with a differential receiver board (the one with 4 outputs and only one ethernet connector). i am using ws2815 pixels (same protocol as ws2811).


i am using the latest b22 firmware.


i have tried juts about every combination of string/port/serial settings, after first trying the way listed in the manual.


lets say im using "main board only" mode in the string port configuration, then i set the serial port to pixel data and choose serial port #1 as index (or ,2,3,4 (the only other options))


i cant get anything to output from those outputs, including the test mode on the controller, but the leds are definitely getting power as even though they are black they put out a lil bit of heat (typical of ws2815).


appreciate any help as im running out of ideas of what things to try.
Title: Re: trouble using differential receiver board on serial port
Post by: David Pitts on April 05, 2019, 01:01:28 AM
The F4 only has one serial port. So ports 2,3 and 4 on receiver will not work. Port 1 should.
Title: Re: trouble using differential receiver board on serial port
Post by: Pineapple on April 05, 2019, 02:21:41 PM
thanks for the input david. i have tried selecting port 1 and it does not work.
(when i select "board w/ one expansion" it opens up options to select ports 1-12, but ive played with those settings as well and still cant get any output out of the expansion board) does the fact that they two boards share a power supply create an issue?