Falcon Christmas

Falcon Christmas => Falcon Smart String Utility => Topic started by: dandameron on January 24, 2017, 02:34:02 PM

Title: SOLVED - WS2811 bullets nodes and SSC's
Post by: dandameron on January 24, 2017, 02:34:02 PM
Has anyone had luck using WS2811 bullet nodes and the modded SSC's(using the latest firmware and programming utility)?
I can't get any of the WS2811 bullet nodes (some bought last year from Holiday Coro and new ones bought this year from Ray Wu) to work with SSC's... older bullets (1809, i think) work great...

thanks !
Dan
Title: Re: WS2811 bullets nodes and SSC's
Post by: MrChristmas2000 on January 24, 2017, 03:17:43 PM
If you are talking about RJs SSCs I can't tell you but if you have the micro SSCs then those drive 2811s no problem.

Title: Re: WS2811 bullets nodes and SSC's
Post by: twooly on January 24, 2017, 03:38:18 PM
Yep I've got DLA SSC running the falcon firmware driving 2811s just fine.
Title: Re: WS2811 bullets nodes and SSC's
Post by: dandameron on January 24, 2017, 05:40:06 PM
Thanks, guys, for the response...
Yep, they are DLA SSCs modded to V3 (latest Falcon firmware and software)...
Twooly: what version are you running?
Dan
Title: Re: WS2811 bullets nodes and SSC's
Post by: twooly on January 24, 2017, 06:18:57 PM
V3 and V4
Title: Re: WS2811 bullets nodes and SSC's
Post by: dandameron on January 24, 2017, 06:36:18 PM
Thanks !
If I send you one of my modded SSC (V3 that work for my 1809's) and some of the WS2811, could you check to see if they work on your end? I would pay for postage both ways...
Also, I've tried these w/DLA active hubs AND Falcon pixelnet hub... same thing... no luck...
Dan
Title: Re: WS2811 bullets nodes and SSC's
Post by: twooly on January 24, 2017, 06:45:23 PM
Before we do that lets see if we can get it figured out so you don't have to spend the money


I assume they are working 2811s that you can get working on another controller?  Do you see power at the start of the pixels when you connect them up?  Can we make sure its not a universe/channel problem and try channel 1 for the programming.  When you do the "send all" option do you get any flashing on the pixels?
Title: Re: WS2811 bullets nodes and SSC's
Post by: dandameron on January 24, 2017, 07:13:00 PM
Thanks...
Yep, the pixels work fine when connected to a falcon V1 pixelnet board... I can access each individual pixel when testing in XLights on the falcon board... I'm using an EtD (actually 2 EtD's) to send data to the pixels... I have 1 EtD programmed for universes 1-32 and the other one for universes 33-64... both send correct data based on the programming (the  first EtD sends data to the DLA/Falcon hub board based on universe 1... each board set to 1,1 and the SSC's are programmed for the appropriate #s)... The SSC's have Falcon 1.0.11 firmware and are set up using the Falcon SSC programmer (V 1.0.12)... everything works great using the old 1809 pixels (including the second EtD programmed for universes 33-64), but can't get any of the WS2811 pixels to respond... I've triple checked the +12, Gnd, and data... David Pitts replied to an email I sent (we both live in Co. Sp.) and said he had no trouble with the 2811's...
Thanks for your help !!
Dan
Title: Re: WS2811 bullets nodes and SSC's
Post by: twooly on January 25, 2017, 08:59:47 AM
Post up some pictures of the SSC/Pixels Connected/Hubs/Screenshots of config tool with one SSC selected of how you are configuring.
Title: Re: WS2811 bullets nodes and SSC's
Post by: dandameron on January 25, 2017, 06:16:09 PM
Well, I've spent the better part of two days trying to get my WS2811 pixels (some new and some older) to work with my modded to Ver 3 DLA SSCs using the most recent Falcon firmware and software... no luck... the funny thing is that the WS2811 RECTANGLES that I purchased from Holiday Coro at the same time I purchased the older WS2811 bullet pixels (that I can't get to work) work fine. I have a short video of the WS2811 bullet pixels working fine on a Falcon V1 board using the test function (but the video is too big to attach... 7 gig instead of 5 gig max). The new WS2811 pixels from Ray Wu (purchased this year) also work fine on the Falcon board, but not with the modded DLA SSCs...
Twooly... if you are OK with this, I will send you a few of the WS2811 pixels I have (prepaid send and return) to see if you can get them to work on your SSCs... my email is: dan dot dameron at comcast dot net...
Thanks for your help!
Dan
Title: Re: WS2811 bullets nodes and SSC's
Post by: arw01 on January 25, 2017, 07:41:00 PM
how long of a pigtail from the V3 to the ws2811?

have you reflashed the pic by chance?  Seen some just loose their mind and need a eeprom reprogram for no reason other than they did.
Title: Re: WS2811 bullets nodes and SSC's
Post by: dandameron on January 25, 2017, 07:50:02 PM
pigtail about 10"... yep... re-flashed several times, just to make sure... and re-programmed the SSC... works great with any bullet pixel other than the WS2811 pixels...
Title: Re: WS2811 bullets nodes and SSC's
Post by: bcstuff on January 25, 2017, 08:39:58 PM
Just throwing this out there,
any chance the pixels are not 2811?

If you are on a F16V2 it can run several different types of pixels that the SSC cannot run.


I just had another though too, If you have a flaky first pixel the SSC may not be able to effectively drive past the flaky pixel and the lights would possibly not work. The F16 has a strong drive circuit that could effectively drive the string through the flaky pixel.

I have had SSCs that did not run a string properly (sticking on, flickering, rainbows), dropped a uAmp onto the output and worked perfectly.
Title: Re: SOLVED - WS2811 bullets nodes and SSC's
Post by: dandameron on January 26, 2017, 02:57:59 PM
It seems that the most basic things that we take for granted don't always work... the ONE new pigtail that I used to test the WS2811 pixels had a pin that had no continuity (I FINALLY checked that after everything else didn't work... go figure)... so, everything is now working as it should... thanks to all who took the time to read and suggest a solution! (BTW, ALL of the other 24 pigtails check-out fine)
Dan
Title: Re: SOLVED - WS2811 bullets nodes and SSC's
Post by: MrChristmas2000 on January 26, 2017, 03:08:11 PM
Glad you got it working. Its the least expected things that can be the most annoying of problems.



Title: Re: SOLVED - WS2811 bullets nodes and SSC's
Post by: twooly on January 26, 2017, 07:31:47 PM
Awesome glad to hear you got it going.
Title: Re: SOLVED - WS2811 bullets nodes and SSC's
Post by: arw01 on January 26, 2017, 08:23:56 PM
I don't find many pigtails bad, but I test every single one and every extension every time before I use them.
Title: Re: SOLVED - WS2811 bullets nodes and SSC's
Post by: MrChristmas2000 on January 27, 2017, 04:04:59 AM
I have a couple of bad ones. I also test them but sometimes things go bad with use.