Falcon Christmas

Sequencers and Software Tools => XLights/Nutcracker => Topic started by: KBCoggin on November 18, 2018, 02:20:35 AM

Title: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 18, 2018, 02:20:35 AM
I ordered a model from Boscoyo, but they do not have an xlights model for it yet.  I would like to make one using the "Generate Custom Model" feature of xlights.  The channel information is good because the light are working with a different model I found in xlights.  My controller (10.0.0.100) is hooked up to the FPP via ethernet.  The Pi is on same network as my computer via the wlan connection.  I configured the outputs in Xlights to the wlan IP address of my Pi.  But when I try to output my sequence (or anything really) from xlights I am not seeing any lights.  Does anyone have any experience in this area?
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: Emuney18 on November 18, 2018, 05:25:17 AM
The xlights IP should be the controller not the Pi.


Sent from my iPhone using Tapatalk
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 18, 2018, 09:00:05 AM
The xlights IP should be the controller not the Pi.


Sent from my iPhone using Tapatalk
The controller is not on the same network as my computer though.  If I set the IP to the controller, how will Xloghts know to send the signal to the bridged Pi?

The outputs on the Pi are set to the IP of the controller.
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: JonB256 on November 18, 2018, 02:43:42 PM
Is your Pi connected by Wireless?

and the Pi's RJ-45 then connected to the "other" controller - you've never described what it is.

If your controller has an IP address, can't you just run a CAT5 to it ?  or do you need to access it through the Wireless Pi ?
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 18, 2018, 03:17:50 PM
Is your Pi connected by Wireless?

and the Pi's RJ-45 then connected to the "other" controller - you've never described what it is.

If your controller has an IP address, can't you just run a CAT5 to it ?  or do you need to access it through the Wireless Pi ?
Yes, Pi's wlan is connected wireless to my home network router (as is my computer). Pi's RJ-45 is connected to my F16v3 (stupid I didn't mention that earlier...)
 
I am trying to send data from xlights on my computer to the controller - which I believe should be possible via bridge mode on FPP.  But I am having trouble figuring out how to configure everything to successfully do so. 

Yes, I could connect the controller to my computer directly, but that would require me to run a network cable across my workshop, which I don't really wanna do if I don't have to.
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: JonB256 on November 18, 2018, 09:29:37 PM
What you are wanting to do is pretty common (Jim Nealand and many others, including me last year)

On the FPP's networking page, bottom left, you must check that box to Enable Routing (routing between wlan0 and eth0)

Then on your PC, you need to add a Routing Command so that your PC knows that, in order to talk to your Falcon, it must go through the Pi.

post the IP addresses for both your Pi and the F16 here and someone can give you the correct syntax.

Once that is done, on the F16v3, you need to change its Gateway setting to the IP address of the Pi
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 18, 2018, 11:56:13 PM
What you are wanting to do is pretty common (Jim Nealand and many others, including me last year)

On the FPP's networking page, bottom left, you must check that box to Enable Routing (routing between wlan0 and eth0)

Then on your PC, you need to add a Routing Command so that your PC knows that, in order to talk to your Falcon, it must go through the Pi.

post the IP addresses for both your Pi and the F16 here and someone can give you the correct syntax.

Once that is done, on the F16v3, you need to change its Gateway setting to the IP address of the Pi
I have enabled the Routing on FPP.  FPP eth0 is 10.0.0.200.  wlan is 192.168.1.247
F16v3 Controller is at 10.0.0.100
I have added the persistent route in windows ("route -p ADD 10.0.0.100 MASK 255.255.255.0 192.168.1.247" - got the OK!)
I have updated the controller to gateway 10.0.0.200
Enabled Bridge Mode on the FPP
Enabled "Output to lights" on xlights
In xlights my channels are set to unicast, 10.0.0.100


But I am still not seeing lights when I play from xlights.


I was using DHCP for the wlan on the pi, but I changed it to static just in case that might cause and issue later.  So far, the Pi wlan IP has never changed but now it cannot :)
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 19, 2018, 12:09:16 AM

UPDATE: I tried to ping the controller and could not.  So then I went to check the persistent route and it was missing... added it again and PRESTO!  I can ping the controller now, AND I can send data to the pixels from my computer.  THANK YOU SO MUCH!


Now I just need to TS why some of my lights are blinking rapidly when I send the sequence to them.
Title: Re: Generate Custom Model Issue - FPP Bridge Mode
Post by: KBCoggin on November 19, 2018, 12:20:32 AM
LAST UPDATE - Took FPP out of bridge mode and into Stand Alone - ISSUE RESOLVED!  8)