News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15659
Latest: PaulDzRGB
New This Month: 9
New This Week: 3
New Today: 1
Stats
Total Posts: 128431
Total Topics: 15791
Most Online Today: 32
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 29
Total: 29

WS2811 Flicker

Started by tmarshall, November 25, 2018, 03:42:52 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

tmarshall

I just finished building twelve 16" snow flakes, (36 pixels each), and twelve 24" snow flakes, (48 pixels each). I hooked them all up one at a time for testing and I am experiencing flicker from 11 out of 12 of the 16" snow flakes, but none of the 24" snow flakes.


I am running them off of an F16V3 controller with FPP. The power out of the controller is about 11.9V. The pixels are 5V, and each snow flake has a Buck converter that drops the 12V output power to 5V. I hooked them up directly to the controller. If I put a uAmp before the snow flake right out of the controller, the flicker goes away. But if I place a second 16" snow flake after the first one, I again get flicker on the second snow flake.


The only major difference between the 16" and 24" snow flakes, other than the number of pixels, is that when I wired the 16" flakes, I cut the strings and added jumpers in several places made of 18AWG SPT-1. With the 24" flakes, there are no jumpers.


Has anyone seen anything like this? Could short two or three inch jumpers made of SPT-1 cause this?

tmarshall

I think I figured it out.  I read on some of the forums that if the voltage is too high, it can cause flicker. The buck converters I am using on the 24" snow flakes is a 5A Drok, and the one I was using on the 16" snow flakes is a 3A CPT. Unfortunately, neither one is adjustable. I tested the out putvoltage of one of each, and the Drok was about 5.02V whereas the CPT was 5.11V. So , I swapped out the CPT buck converter on one of the flickering flakes with a Drok, and Voila, no flicker.

aknflyer

#2
You could try inserting a diode in series with the 12v + to pixels, just make sure the diode stripe is oriented away from the 12v buck. Also be sure the diode is rated for the current you are running in the string. Depending on the diode selected you could drop from .3v to .7v across the diode. Resistors wont work due to the varying load during the sequence, diodes always drop a exact voltage depending on the specs. The spec you would look at is Ifwd or maximum forward current. The other spec is Vf or voltage drop forward, i.e. how much voltage is dropped when conducting.

Support FPP

+- Recent Topics

Warning/Error: Network incomplete frames hit 250. by JonD
February 06, 2023, 04:10:22 PM

F16V3 with 2 expansion boards at 40 fps MAX PIXELS per output? by tbone321
February 06, 2023, 10:51:55 AM

F48V4-NS at 40 fps using all 48 pixel output ports? by Poporacer
February 06, 2023, 10:27:09 AM

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod