LATEST RELEASE:  FPP 7.2 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16349
Latest: bweber
New This Month: 136
New This Week: 6
New Today: 0
Total Posts: 130967
Total Topics: 16211
Most Online Today: 101
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 60
Total: 66

Ran into a no Internet access when using both WiFi and Ethernet, but fixed it.

Started by greggsuter, August 09, 2022, 08:01:43 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


My Pi4's are all running v6.0.2-2-ga4eeb9cf (v6.0 branch), which is the latest as of this post.

I've never had this issue with FPP 5.x I ran last season, but basically if I have the Pi4 connected to both WiFi (my home network for Internet and file transfers from XLights, and just basic access to the FPP web interface) and Ethernet (show network only; connects all of the E1.31 controllers and another Pi4 as a remote player...also configured the same way for WiFi).  I also have a Netgear WiFi bridge on the show network acting as an access point so I can access the show network directly without interfering with my home network, and it also has a built-in DHCP server, but doesn't affect the FPP devices or E1.31 controllers since they're all on a static IP.

IP addresses are on my WiFi side and on the Ethernet side.  WiFi is on DHCP and gets the information from my home network.  Ethernet is static.

If I were to disconnect the Ethernet cable from the Pi4, it immediately gets Internet access, but then will not be able to send data to the E1.31 controllers.  Soon as I reconnect Ethernet, Internet access disappears but I can still access the interface on the FPP from my home network, just no Internet access on FPP.

I ended up setting the Gateway IP address on the Ethernet side to the IP address of my router on my home network ( in order to get Internet access.  I also have DNS set to, but that still didn't work until I reconfigured the Gateway to my router IP address.

Same exact thing on the remote player, and also got it fixed with those same settings.

My "test" Pi4 is only on a WiFi network and I just use it for testing purposes, so it has never had issues with connecting to the Internet.

I need to have Internet access on the FPP devices for SmartThings (to power on my E1.31 controllers, and other items I have automated), Remote Falcon, and so I can update FPP and/or update or install Plugins.

Since this issue seemed to be a new issue, I thought I'd send this post out for other users to see and to the developers for reference.  Hopefully it will help other users if they run into this issue also.


You shouldn't have a gateway on the eth0 interface in this situation.  Is that the way you had it to begin with?  If both interfaces have (different) default gateways configured, the traffic will go out the first interface listed in the routing table which is normally eth0.


Haven't tried deleting the gateway entirely, but i'll experiment with that also.


Quote from: greggsuter on August 09, 2022, 09:29:49 PMHaven't tried deleting the gateway entirely, but i'll experiment with that also.

You should normally only have a single gateway configured, and that should be on whatever interface has the path to the internet.


Registered an account just to say thank you for this post, it saved me!  I have a similar network setup with the show running on eth0 on a segregated network that has no internet.  My issue was that it appears that FPP will only utilize NTP service over eth0.  So in order for my schedule to run at the correct times, I needed the service to run over wlan.  The only thing that resolved the issue was putting the gateway of the wlan network on the eth0 network settings.

Support FPP

+- Recent Topics

v1.03 Smart Receiver parts by tbone321
Today at 01:58:02 PM

AC lights on arches not working by jonmtme
Today at 01:34:45 PM

FPP Freeze Monitor by robbiet
Today at 12:18:57 PM

pi 3 b+ by stingray124
Today at 09:37:08 AM

Disabling Logs by
Today at 09:15:18 AM

FPP v6.3 with K16A-B not reacting to DDP from Vixen by tbone321
Today at 08:38:22 AM

Is there a way to auto-restart FPPD ? by Ebuechner
Today at 08:02:08 AM

Smart Receiver difficulty with F48V4 controller by JonD
Today at 05:35:07 AM

F48v4-NS Network Light Flashing, No connection by JonD
Today at 05:15:16 AM

FPP 7.3 Network by JonD
Today at 04:32:44 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod