Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16460
Latest: tripleblack
New This Month: 10
New This Week: 1
New Today: 0
Total Posts: 132598
Total Topics: 16443
Most Online Today: 221
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 187
Total: 188

Resetting or Removing FPP Password (with Windows)

Started by greenreader9, April 12, 2024, 10:03:53 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hello! Hoping someone here can help me out :)

I setup FPP initially around November, and got it working with the lights just the way I wanted it. I finally got around to start soldering my custom PCB's and such to make things easier. Just finished soldering the first one, and went to test it, but I locked myself out of FPP. I can't login via the UI (I get the htaccess password pop-up), and I can't login via SSH (I get the wrong password message.

--Continued in comment below due to message length limit--


The defaults (fpp / falcon and fpp / christmas) don't work (Tried doing "Falcon" and "Christmas" as well). I imagine I changed it to something else, but my dumb self apparently used a unique password and never wrote it, or a password hint down anywhere (Least not that I can find).

I pulled the SD card out and brought it into Windows, and opened it with DiskInternals Linux Reader. Could not find a htaccess or htpasswd file anywhere. I have a feeling that the file is in the highlighted partition, but I don't know how to get to it. I really don't want to re-install since I know I spent a few hours getting it setup in November.

Thanks for any assistance you can offer!


The htpasswd and htaccess files are on the other, large partition.  The normal file paths for FPP are /home/fpp/media/config/.htpasswd and /home/fpp/media/config/.htaccess

I don't think that you can update those using the Linux Reader, but you should be able to see the passwords you configured during the initial setup by looking at the /home/fpp/media/settings file and then you can boot the SD card back up and login remotely.


Thanks for your response!

I figured the files were in there somewhere, but thanks for the confirmation! Knowing the file paths will also save me some time I'm sure.

I managed to get the partition open in DiskInternals, but since there is no edit access or anything there, I attempted to open it in Ex2 Volume Manager where I just get "This file is write protected" notices from Windows (And apparently EX2 does not support EXT4 partitions).

Saw something that pointed me to the WSL tool built-in to windows, so I installed that, and Ubuntu 22.04 to get WSL2 installed. Turns out that there is some long-standing issue with Raspberry Pi SD cards and that program that MS seems unwilling to fix (Link)

I was able to read the .htaccess file with says my username is "Falcon Player", and the config file listed the name as "primary" and the password as "raspberry", but no combination of those (Including using Title Case) worked for getting into the WebUI, FTP, or SSH.

Any other thoughts on how I can delete the .htpasswd file and edit out the "Auth" lines in .htaccess?



A couple things. 
Setting a UI password is like putting a lock on youre refrigerator in case someone breaks into your house. If someone has hacked your network, the only thing that the UI password will prevent is someone scheduling Baby Shark over and over. It doesn't provide any network security.
I don't think there are any tools that will allow you to view/edit the partition info on a Windows machine outside of a Virtual Machine running Linux.
If you were to have just re-imaged the card, you would have been back up and running yesterday. It only takes about 20 minutes and with xLights able to manage most things it is a simple process. 
This might help?
If to err is human, I am more human than most people.


The password is in the settings file I mentioned.


Quote from: Poporacer on April 13, 2024, 07:29:47 PMIf you were to have just re-imaged the card, you would have been back up and running yesterday.
Yeah I realize that. However, I would really like to learn how this works as well, not just restart and not learn anything. I totally get where you are coming from though :)

Quote from: CaptainMurdoch on April 13, 2024, 08:04:33 PMThe password is in the settings file I mentioned.
I see the password, but it won't let me log in using it

So the UI username is "Falcon Player"

and the password is "raspberry".

That combo won't let me login to the UI though.

Also tried logging into FTP with username "Falcon Player" and "primary", both with password "raspberry":

If I use the FTP protocol (Port 21), I get "Could not connect to server"

Trying with SSH (Tried passwords 'raspberry', 'primary' and 'Falcon Player' for each attempt):

Is there anything I am doing wrong here, or is something just broken somewhere else?



UI login is "admin" and ssh login is "fpp".


Quote from: PixelsAndPepsi on April 14, 2024, 01:32:58 PMUI login is "admin" and ssh login is "fpp".
Thank You! 

(I am also now realizing the stupid mistake I made of thinking "AuthName" was the username and not the user prompt)

SSH still won't work but I don't really care since I have access to the UI now

Thank you again!

Support FPP

+- Recent Topics

Did the the latest upgrade tonight and it failed. by MikeKrebs
June 10, 2024, 09:19:42 PM

No Audio by Steve
June 07, 2024, 02:10:47 PM

Video IP Capture -> sound by MikeKrebs
June 06, 2024, 09:00:17 PM

Control Channel Output by zj023
June 03, 2024, 06:23:35 AM

Compatibility question by John_82
June 02, 2024, 04:23:25 PM

Virtual Display not working? by colonelcline
June 01, 2024, 04:55:41 PM

Help for my LED Pit board project by Octonath
May 31, 2024, 06:15:17 PM

Help, can't get PCA9685 working with xLights and FPP by dkulp
May 30, 2024, 08:54:53 AM

HELP Did something dumb - turned on Tethering by The Engineer
May 27, 2024, 06:39:38 PM

First Time User - Can't open GUI only Terminal by k6ccc
May 27, 2024, 09:51:34 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod