Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15659
Latest: PaulDzRGB
New This Month: 9
New This Week: 3
New Today: 0
Total Posts: 128433
Total Topics: 15791
Most Online Today: 48
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 24
Total: 24

can't stay logged in to FPP 1.5

Started by AAH, December 11, 2015, 05:45:08 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


  FPP was worked excellently for me over the last week and a bit running my show. Yesterday I attempted to update some sequences as I'd made some changes and I couldn't log in at all. Upon further experimentation I can log in in the few seconds after boot up when it announces the IP but after then I can't do anything. I am fairly loathe to do an upgrade as the show is currently working well and if it's not broken don't fix it is my motto.
  It may be coincidence but I have now noticed that there is a big green banner saying 1.6 is available which I can't say I noticed before. My version is Version: v1.5-56-g99cb1c1  Host: FPP and it's on I can ping the PI at any time on and it pumps out data to my show fine. To stop the PI pumping out gazillions of bytes while I am trying to access it I have edited the schedule on the SD card so it doesn't start until 1-1-2016. This has stopped the show running but hasn't allowed me to access FPP to make changes.
  Help me Obi Wan you're my only hope.

As a temporary fix I will do my display testing from PC and update direct to the SD card but I need my direct FPP access back and I'm hoping I don't have to do a forced update to 1.6.


I would check the network cable and switch to see if it is running in half duplex or 10mbit speed.

The v1.6 upgrade is optional and I recommend the "if it ain't broke, don't fix it" approach for people during the holiday season.


I've rebooted the 2 computers that connect to the PI, the PI 5 times while connected to router, about 10 times while directly connected to laptop. At all times I can ping FPP but can log in for maybe 1s or so before I get a timeout when trying to do it again. I've tried it with FF and IE.


The last few times something like this has happened to someone over the past few weeks, it was because they created a repeating playlist with only an event in it, so FPP happily kept looping, firing off the event in the background over and over until it consumed all the memory and CPU on the system.  Have you created any new scheduled playlists lately?  When it is playing, is it playing audio?  Maybe audio is misconfigured and it is looping the repeating playlist but skipping each entry because it can't play audio.


I haven't changed the playlist for about 4 days and the problem only occurred yesterday.
Everything plays fine but I can't access the web interface beyond about a second or 2 after the IP is announced.
Changing the schedule for a 2016 start stops everything from playing but I still get locked out within seconds.
Has there been some sort of code "push" for that green version 1.6 notification?


The v1.6 notification was pushed about a month and a half ago with only a few minor bugfixes since then and nothing that should cause what you are describing.

Can you ssh into the system and run 'top' to see what is running that seems to be locking you out?  does the system lag at all when this happens, or do the audio and sequence play at normal speed?

If you want to revert to an older version, you can go to and pick a SHA1 hash (the 7-digit hexadecimal number in the box on the right) and try reverting to one of those versions by running the following:

cd /opt/fpp

I would also try shutting down and putting in a different empty USB stick and seeing if that allows the system to stay up and running.  If so, then it sounds like the issue is related to the configuration on the USB stick or the USB stick itself.

Here are the changes since the v1.6 upgrade button was added:

commit 99cb1c1a4a208923e9525a5edf2de06ebe4657b3
Author: Chris Pinkham <>
Date:   Thu Oct 29 23:58:16 2015 -0700

    [Scripts] Run upgrade_config as root during a manual update
    (cherry picked from commit 9f2a2f2042de37c8a756ccc4ffcf0643a95b34c2)

commit 331c6093bec91f5c4b8364cd0687ff48528f4193
Merge: 220ee73 2ebac96
Author: Chris Pinkham <>
Date:   Mon Nov 16 00:17:11 2015 -0800

    Merge pull request #170 from rawcreative/1.5-cache-fix
    [UI] Add cache busting for fpp.js

commit 220ee73ed28fc9e08a50b92b064ecdd12e669037
Author: Chris Pinkham <>
Date:   Tue Nov 10 09:21:50 2015 -0800

    [UI] Update EDM plugin SHA1 for v1.5+
    (cherry picked from commit 43151ec9baabd73e4a806f6d081e2bd32447aafb)

commit f922fca660b510706c2ecd8bf0005c5aa3aaf791
Author: Mathew Mrosko <>
Date:   Tue Nov 3 22:10:18 2015 -0800

    [plugins] Update VastFMT plugin for Pi2 support and add explicit pthread link for all Pi builds.
    (cherry picked from commit dfd19e727df46b73f9ad81996f08bc56678a954c)

commit 7c4a28e2076b920c78be699f691514b5db83d094
Author: Mathew Mrosko <>
Date:   Tue Nov 3 21:11:45 2015 -0800

    [plugins] Update VastFMT plugin for recent bug fixes.
    (cherry picked from commit 2e7d6383283231841dd01a619b7275482c937ef8)

commit 3692dba23165c12d793f6c86db6573e858a49f23
Author: Chris Pinkham <>
Date:   Mon Oct 26 19:46:28 2015 -0700

    [Network] Reinstall 8192cu.ko module if previous attempt failed
    (cherry picked from commit 4ed2cfc7529aec98bb3b95efc6ec53c905ff0f37)

commit 253f1855dca2d8ffdf4803e4d43924996339e280
Author: Chris Pinkham <>
Date:   Mon Oct 26 14:55:09 2015 -0700

    [Plugins] Add Sports Ticker plugin
    (cherry picked from commit 52507292bc477b278469e7ec9530a96d0dc3ba26)

commit 2ebac9681ff2c451eefef4fc3fb4e088bd31f02e
Author: Tim Debo <>
Date:   Mon Oct 26 13:17:53 2015 -0400

    Add cache busting for fpp.js
    Quick mod to prevent end user issues with cached versions of fpp.js

commit f4007972386c57e6b8039b5e8e9f5514f979cebc
Author: Chris Pinkham <>
Date:   Sun Oct 25 23:30:11 2015 -0700

    [UI] Fix volume resetting to 75 caused by = vs ==
    (cherry picked from commit ddef07a3fdadd0ccbdac563a518d94caa8827b07)

commit 5f34abfe31190cdcd0dd1ae7a9285f96eb177cc5
Author: Chris Pinkham <>
Date:   Sat Oct 24 21:52:49 2015 -0700

    [UI] Enable FPP v1.6 upgrade button in UI



  Thanks for your time Chris. I ended up ssh'ing into the PI via trial and error and below is the screenshot of what showed. There doesn't appear to be anything out of the ordinary from what I could see. I then thought I'll try swapping usb drives and for the sake of getting going quicker I thought I'd copy all the files across and then remove the playlist type files. In the process of copying stuff across I discovered that the startup.log file was corrupt and that appears to be enough to kick me to the curb. I'm now up and running again and the 1st thing I did was turn off all logging :)
  I'm guessing that the file may have been corrupted through a partial power cycle on startup and because it has become corrupt the fpp code bangs it's head in the background against it trying to get some sense into it.


There isn't anything being written to the startup log once fppd starts.  If it was related I would expect it was the kernel trying to flush the cache to the USB stick and corrupt file.

Glad you for it working.

Support FPP

+- Recent Topics

F16V3 with 2 expansion boards at 40 fps MAX PIXELS per output? by BirdingPix
Today at 02:49:02 PM

Warning/Error: Network incomplete frames hit 250. by JonD
Today at 10:59:15 AM

F48V4-NS at 40 fps using all 48 pixel output ports? by Poporacer
February 06, 2023, 10:27:09 AM

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod